summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormauriciodelima212023-09-03 00:32:10 -0300
committermauriciodelima212023-09-03 00:32:10 -0300
commitaadee6d43d15fc99c2848a7ad2d0f78eb5541569 (patch)
tree2fdbca09764f41d76ef2e63f1e5931ae495fb7ed
downloadaur-aadee6d43d15fc99c2848a7ad2d0f78eb5541569.tar.gz
Commit inicial
-rw-r--r--PKGBUILD24
-rw-r--r--calamares-config.install30
2 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d38d0dca9f50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mauricio de Lima <emauricio@uai21.com>
+pkgname=calamares-config
+_destname1="/etc"
+pkgver=71
+pkgrel=1
+pkgdesc="Calamares for Archiso"
+arch=('any')
+url="https://github.com/UaiSO21"
+license=('GPL3')
+makedepends=('git')
+#depends=('')
+provides=("${pkgname}")
+options=(!strip !emptydirs)
+source=(${pkgname}::"git+${url}/${pkgname}")
+sha256sums=('SKIP')
+if [ -e "${pkgname}.install" ];then
+ install=${pkgname}.install
+fi
+package() {
+ install -dm755 ${pkgdir}${_destname1}
+ cp -r ${srcdir}/${pkgname}${_destname1}/* ${pkgdir}${_destname1}
+}
+
+
diff --git a/calamares-config.install b/calamares-config.install
new file mode 100644
index 000000000000..747a227a1439
--- /dev/null
+++ b/calamares-config.install
@@ -0,0 +1,30 @@
+## arg 1: the new package version
+#pre_install() {
+# locale-gen
+#}
+
+## arg 1: the new package version
+#post_install() {
+#
+#}
+
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+post_remove() {
+ /usr/bin/sed -i 's/^User=liveuser/User=/' /etc/sddm.conf.d/kde_settings.conf
+}
+