summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaron Hou2020-01-08 18:54:23 +0800
committerGitHub2020-01-08 18:54:23 +0800
commitc3f69453d4661e46a2ef7328ed7ac1f7b0f5dfea (patch)
tree14948ff43aee6d63ecf45d0b98ffbc4145282adc
parent93d200af38018bede34e6e4341345df4f240bbde (diff)
parent6f2afa3bf45b34689f7bb3a44006f64210c9dbf8 (diff)
downloadaur-c3f69453d4661e46a2ef7328ed7ac1f7b0f5dfea.tar.gz
Always provide latest version. (#1)
Always provide latest version.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9831cf70e8f..cd8f9b9ac552 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = archisteamfarm-bin
pkgdesc = C# application that allows you to farm steam cards using multiple steam accounts simultaneously.
- pkgver = 3.4.0.7
+ pkgver = 4.1.1.7
pkgrel = 1
url = https://github.com/JustArchiNET/ArchiSteamFarm
arch = x86_64
license = Apache License 2.0
makedepends = unzip
+ makedepends = curl
+ makedepends = jq
+ depends = dotnet-runtime
noextract = ASF-linux-x64.zip
options = !strip
- source = https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/3.4.0.7/ASF-linux-x64.zip
+ options = staticlibs
+ source = https://github.com/JustArchiNET/ArchiSteamFarm/releases/latest/download/ASF-linux-x64.zip
source = LICENSE-2.0.txt
source = ArchiSteamFarm-bin.desktop
- md5sums = cb87fd7001f5d2cbd9464321d8bcb668
+ md5sums = SKIP
md5sums = 175792518e4ac015ab6696d16c4f607e
md5sums = 98654afd36cae629f570ff0510669ba2
diff --git a/PKGBUILD b/PKGBUILD
index 9b003a81ef99..e3440c56b2e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,45 @@
# Maintainer: Baron Hou <houbaron@gmail.com>
pkgname=archisteamfarm-bin
-pkgver=3.4.0.7
+pkgver=4.1.1.7
pkgrel=1
pkgdesc="C# application that allows you to farm steam cards using multiple steam accounts simultaneously."
arch=('x86_64')
url="https://github.com/JustArchiNET/ArchiSteamFarm"
license=("Apache License 2.0")
-makedepends=("unzip")
+depends=(dotnet-runtime)
+makedepends=("unzip" "curl" "jq")
noextract=('ASF-linux-x64.zip')
-options=("!strip")
+options=("!strip" "staticlibs")
source=(
- "https://github.com/JustArchiNET/ArchiSteamFarm/releases/download/${pkgver}/ASF-linux-x64.zip"
+ "https://github.com/JustArchiNET/ArchiSteamFarm/releases/latest/download/ASF-linux-x64.zip"
"LICENSE-2.0.txt"
"ArchiSteamFarm-bin.desktop"
)
md5sums=(
- 'cb87fd7001f5d2cbd9464321d8bcb668'
+ 'SKIP'
'175792518e4ac015ab6696d16c4f607e'
'98654afd36cae629f570ff0510669ba2'
)
+pkgver() {
+ curl -s https://api.github.com/repos/JustArchiNET/ArchiSteamFarm/releases/latest | jq -r '.tag_name'
+}
+
prepare() {
- unzip ASF-linux-x64.zip
+ rm -rf "ASF"
+ unzip ASF-linux-x64.zip -d "ASF"
}
package() {
install -Dm644 "LICENSE-2.0.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "ArchiSteamFarm-bin.desktop" "${pkgdir}/usr/share/applications/ArchiSteamFarm-bin.desktop"
- install -Dm755 "ArchiSteamFarm" "${pkgdir}/opt/ArchiSteamFarm-bin/ArchiSteamFarm"
- cp -r "${srcdir}"/* "${pkgdir}/opt/ArchiSteamFarm-bin/"
+ install -Dm755 "./ASF/ArchiSteamFarm" "${pkgdir}/opt/ArchiSteamFarm-bin/ArchiSteamFarm"
+ cp -r "${srcdir}/ASF"/* "${pkgdir}/opt/ArchiSteamFarm-bin/"
+
+ rm -f "$srcdir/../ASF-linux-x64.zip"
}
+