summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-03-04 22:01:07 +0100
committerCarl Smedstad2024-03-05 09:18:37 +0100
commit6be3653bdae7d7d2d823ea7225fa53ae83e8fe4f (patch)
tree9efbe2bdfc3b5893b0d6ee76b0135d9048f05f1c
parent2af8e1e2d0786e61f3ecf2b96193d5bbdcd1ddd1 (diff)
downloadaur-6be3653bdae7d7d2d823ea7225fa53ae83e8fe4f.tar.gz
upgpkg: 0.7.2-4: Add pkgver() function & fix executable shebang
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41e1a6b61a75..0bb950d86496 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = archivebox
pkgdesc = Open source self-hosted web archiving
pkgver = 0.7.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/ArchiveBox/ArchiveBox
arch = any
license = MIT
@@ -38,8 +38,8 @@ pkgbase = archivebox
source = git+https://github.com/jazzband/django-taggit.git
source = git+https://github.com/tapanpandita/pocket.git
source = git+https://github.com/untitaker/python-atomicwrites.git
- source = django-3.1.14::https://github.com/django/django/archive/refs/tags/3.1.14.tar.gz
- source = django-extensions-3.1.5::https://github.com/django-extensions/django-extensions/archive/refs/tags/3.1.5.tar.gz
+ source = django-3.1.14::https://github.com/django/django/archive/3.1.14.tar.gz
+ source = django-extensions-3.1.5::https://github.com/django-extensions/django-extensions/archive/3.1.5.tar.gz
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 38d681947588..286cb5f739af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=archivebox
_pkgname=ArchiveBox
pkgver=0.7.2
-pkgrel=3
+pkgrel=4
pkgdesc="Open source self-hosted web archiving"
arch=(any)
url="https://github.com/ArchiveBox/ArchiveBox"
@@ -52,8 +52,8 @@ source=(
"git+https://github.com/jazzband/django-taggit.git"
"git+https://github.com/tapanpandita/pocket.git"
"git+https://github.com/untitaker/python-atomicwrites.git"
- "django-$_django_version::https://github.com/django/django/archive/refs/tags/$_django_version.tar.gz"
- "django-extensions-$_django_extensions_version::https://github.com/django-extensions/django-extensions/archive/refs/tags/$_django_extensions_version.tar.gz"
+ "django-$_django_version::https://github.com/django/django/archive/$_django_version.tar.gz"
+ "django-extensions-$_django_extensions_version::https://github.com/django-extensions/django-extensions/archive/$_django_extensions_version.tar.gz"
)
sha256sums=(
'SKIP'
@@ -67,6 +67,12 @@ sha256sums=(
_archive="$_pkgname"
+pkgver() {
+ cd "$_archive"
+
+ git describe --tags | sed 's/^v//'
+}
+
prepare() {
cd "$_archive"
@@ -118,7 +124,7 @@ check() {
cd "$_archive"
rm -rf test_venv
- cp --archive --no-preserve=ownership venv test_venv
+ cp -a venv test_venv
sed -i "s|#!/bin/python|#!$PWD/test_venv/bin/python|" test_venv/bin/archivebox
export PATH="$PWD/test_venv/bin:$PATH"
export PYTHONPATH="$PWD/test_venv/lib/python3.11/site-packages:$PYTHONPATH"
@@ -130,8 +136,8 @@ package() {
cd "$_archive"
install -dm755 "$pkgdir/opt/archivebox"
- cp --archive --no-preserve=ownership venv/* "$pkgdir/opt/archivebox"
- sed -i 's|#!/bin/python|#!/opt/archivebox/bin/python|' "$pkgdir/opt/archivebox/bin/archivebox"
+ cp -a -t "$pkgdir/opt/archivebox" venv/*
+ sed -i 's|#!/usr/bin/python|#!/opt/archivebox/bin/python|' "$pkgdir/opt/archivebox/bin/archivebox"
install -dm755 "$pkgdir/usr/bin"
ln -s /opt/archivebox/bin/archivebox "$pkgdir/usr/bin/archivebox"