summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimlonghao2020-07-29 15:48:23 +0000
committerimlonghao2020-07-29 15:48:23 +0000
commit8dbba5bf4cebbd6c19850dbaf4cc211378e9af9b (patch)
tree812c2bcf5f078eae10f3062435d48ed1282606bf
downloadaur-8dbba5bf4cebbd6c19850dbaf4cc211378e9af9b.tar.gz
New package
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD30
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2dbf6f43c60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = archivebox
+ pkgdesc = The open source self-hosted web archive
+ pkgver = 0.4.9
+ pkgrel = 1
+ url = https://github.com/pirate/ArchiveBox
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-django
+ depends = python-mypy_extensions
+ depends = wget
+ depends = python-crontab
+ depends = python-atomicwrites
+ depends = python-dateparser
+ depends = python-requests
+ depends = python-base32_crockford
+ depends = python-w3lib
+ depends = chromium
+ depends = python-django_extensions
+ depends = git
+ depends = youtube-dl
+ provides = archivebox
+ conflicts = archivebox
+ source = https://files.pythonhosted.org/packages/source/a/archivebox/archivebox-0.4.9.tar.gz
+ sha256sums = f537467af4f1e5b56548c410e54628109b387d5329057a71db7b04f9ae1d979c
+
+pkgname = archivebox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9310d18b063
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Hao Long <aur@esd.cc>
+
+pkgname=archivebox
+pkgver=0.4.9
+pkgrel=1
+pkgdesc="The open source self-hosted web archive"
+arch=("any")
+url="https://github.com/pirate/ArchiveBox"
+license=('MIT')
+provides=('archivebox')
+conflicts=('archivebox')
+depends=('python-django' 'python-mypy_extensions' 'wget'
+ 'python-crontab' 'python-atomicwrites' 'python-dateparser'
+ 'python-requests' 'python-base32_crockford' 'python-w3lib'
+ 'chromium' 'python-django_extensions' 'git'
+ 'youtube-dl')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('f537467af4f1e5b56548c410e54628109b387d5329057a71db7b04f9ae1d979c')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t ${pkgdir}/usr/share/licenses/${pkgname}/
+}