summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanne Heß2016-06-29 15:25:32 +0200
committerJanne Heß2016-06-29 15:25:32 +0200
commitbf9d5c1ff5c9ce873a3e27dc9ac01274de285714 (patch)
tree171948e89ff8430b32852418bcba3c754c637078
parent41387bcb06eed3b169574ca8c7f0be7903670cb0 (diff)
downloadaur-bf9d5c1ff5c9ce873a3e27dc9ac01274de285714.tar.gz
Rename downloaded repository
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47e26fcee2b9..98f2e96b1c7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Jun 29 12:00:00 UTC 2016
+# Wed Jun 29 13:25:23 UTC 2016
pkgbase = archivemount-git
pkgdesc = FUSE filesystem using libarchive
pkgver = 0.8.7.gbb2faa8
@@ -15,7 +15,7 @@ pkgbase = archivemount-git
depends = libarchive
provides = archivemount
conflicts = archivemount
- source = git+http://www.cybernoia.de/software/archivemount/git
+ source = archivemount-git::git+http://www.cybernoia.de/software/archivemount/git
sha512sums = SKIP
pkgname = archivemount-git
diff --git a/.gitignore b/.gitignore
index deaa4562cb3a..dcc48a2deeae 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,4 @@
*.xz
src/
pkg/
-git/
+archivemount-git/
diff --git a/PKGBUILD b/PKGBUILD
index 03477c4952f9..5a6965a2dc30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,17 +10,17 @@ depends=("fuse" "libarchive")
makedepends=("automake" "autoconf" "make")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+http://www.cybernoia.de/software/${pkgname%-git}/git")
+source=("${pkgname}::git+http://www.cybernoia.de/software/${pkgname%-git}/git")
sha512sums=('SKIP')
arch=("i686" "x86_64")
pkgver() {
- cd git
+ cd "${pkgname}"
git describe --tags --always | sed 's/-[[:digit:]]*-/./g'
}
build() {
- cd git
+ cd "${pkgname}"
aclocal
autoheader
automake --add-missing
@@ -30,7 +30,7 @@ build() {
}
package() {
- cd "git"
+ cd "${pkgname}"
install -Dm755 "${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
make PREFIX="/usr" DESTDIR="${pkgdir}/" install-man
mv "${pkgdir}/usr/local/share" "${pkgdir}/usr"