summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSrevin Saju2020-12-30 20:43:28 +0300
committerSrevin Saju2020-12-30 20:43:28 +0300
commit1cc043295a23561743356fbba4b11ba00ad15282 (patch)
tree11ac5f9080308896b9f99688487840ddeb198b8b
downloadaur-1cc043295a23561743356fbba4b11ba00ad15282.tar.gz
initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--00-do-not-pin-requirements.patch12
-rw-r--r--PKGBUILD36
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e813ddc5944
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = archivy
+ pkgdesc = A self-hosted knowledge repository, to preserve useful content to your knowledge bank.
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://github.com/archivy/archivy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-flask
+ depends = python-flask-wtf
+ depends = python-wtforms
+ depends = python-werkzeug
+ depends = python-appdirs
+ depends = python-attrs
+ depends = python-beautifulsoup4
+ depends = python-elasticsearch
+ depends = python-pypandoc
+ depends = python-dotenv
+ depends = python-frontmatter
+ depends = python-requests
+ depends = python-tinydb
+ depends = python-validators
+ depends = python-flask-login
+ depends = python-brotli
+ depends = python-click-plugins
+ depends = python-html2text
+ depends = python-flask-compress
+ optdepends = elasticsearch
+ source = git+https://github.com/archivy/archivy#tag=v0.10.1
+ source = 00-do-not-pin-requirements.patch
+ sha256sums = SKIP
+ sha256sums = 339f305aded981272230193c446307c2731477edf49e9ec6ea684351e5e62b8b
+
+pkgname = archivy
+
diff --git a/00-do-not-pin-requirements.patch b/00-do-not-pin-requirements.patch
new file mode 100644
index 000000000000..6df28996472a
--- /dev/null
+++ b/00-do-not-pin-requirements.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 2a2dd9f..921e594 100644
+--- a/setup.py
++++ b/setup.py
+@@ -32,6 +32,6 @@ setuptools.setup(
+ },
+ include_package_data=True,
+ zip_safe=False,
+- install_requires=install_requires,
++ install_requires=[],
+ python_requires='>=3.6',
+ )
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97ccbb1f6d61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Srevin Saju <srevinsaju@sugarlabs.org>
+
+pkgname=archivy
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="A self-hosted knowledge repository, to preserve useful content to your knowledge bank."
+arch=('any')
+url="https://github.com/archivy/archivy"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python-flask' 'python-flask-wtf' 'python-wtforms'
+ 'python-werkzeug' 'python-appdirs' 'python-attrs'
+ 'python-beautifulsoup4' 'python-elasticsearch' 'python-pypandoc'
+ 'python-dotenv' 'python-frontmatter' 'python-requests'
+ 'python-tinydb' 'python-validators' 'python-flask-login' 'python-brotli'
+ 'python-click-plugins' 'python-html2text' 'python-flask-compress')
+optdepends=('elasticsearch')
+source=("git+https://github.com/archivy/archivy#tag=v$pkgver"
+ "00-do-not-pin-requirements.patch")
+sha256sums=('SKIP'
+ '339f305aded981272230193c446307c2731477edf49e9ec6ea684351e5e62b8b')
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git apply "$srcdir/00-do-not-pin-requirements.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}