summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-07-07 00:19:25 +0000
committerPellegrino Prevete2022-07-07 00:19:25 +0000
commite467f35e3575501a2aca3c4156a2ab05a058769d (patch)
tree21da04d13b5528e118801a915a66d860d60916f7
parent710f0d7146f9653dcedaf368825e3adeb4e5105c (diff)
downloadaur-e467f35e3575501a2aca3c4156a2ab05a058769d.tar.gz
update
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3a28c945da7..6e2a4742fcad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkg="archiso"
_distro="archlinux"
_pkgbase="${_pkg}-profiles"
-_profile=desktop
-pkgname="${_distro}-${_profile}"
+profile=desktop
+pkgname="${_distro}-${profile}"
pkgver=v0.1+11+g1afb2fc
pkgrel=1
pkgdesc='Builds an Archlinux desktop'
@@ -19,7 +19,7 @@ depends=('archiso-persistent-git'
'mkinitcpio-archiso-encryption-git'
'plymouth-nested-cryptkey'
'polkit')
-makedepends=('devtools' 'git')
+makedepends=('devtools' 'git' 'archiso-profiles-git')
checkdepends=('shellcheck')
source=("git+${url}")
sha256sums=('SKIP')
@@ -32,12 +32,12 @@ pkgver() {
package() {
# shellcheck disable=SC2154
local _dest="${pkgdir}/usr/share/${_distro}"
- local _profile="${srcdir}/${_pkgbase}/${_profile}"
+ local _profile="${srcdir}/${_pkgbase}/${profile}"
local _build_repo="${srcdir}/${_pkgbase}/.gitlab/ci/build_repo.sh"
+ cp -r "/usr/share/archiso-profiles/${profile}" "${_profile}"
cd "${_profile}" || exit
-
mkdir -p work
- _build_repo "fakepkg"
+ "${_build_repo} fakepkg"
install -d -m 0755 -- "${_dest}"
pkexec mkarchiso -v \
-o "${_dest}" \