summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2016-05-20 00:06:41 +0200
committerredtide2016-05-20 00:06:41 +0200
commita856fffc8ddf41718c87056ed16891a1455c64d1 (patch)
treed90657affd12527a6ee32b9874617f058f29fe45
downloadaur-a856fffc8ddf41718c87056ed16891a1455c64d1.tar.gz
First commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--archlinux-lxdm-theme-full.install9
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dab0c285d9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = archlinux-lxdm-theme-full
+ pkgdesc = Arch Linux GTK2/3 theme for LXDM
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/redtide/lxdm-theme-archlinux/
+ arch = any
+ license = CCPL:by-sa
+ depends = lxdm-gtk3
+ conflicts = archlinux-lxdm-theme
+ conflicts = lxdm-themes
+ source = git://github.com/redtide/lxdm-theme-archlinux.git
+ md5sums = SKIP
+ install = archlinux-lxdm-theme-full.install
+
+pkgname = archlinux-lxdm-theme-full
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0c70b2f5edd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: RedTide
+# Original authors: Thayer Williams and Allan McRae
+
+pkgname=archlinux-lxdm-theme-full
+pkgver=0.1
+pkgrel=1
+pkgdesc="Arch Linux GTK2/3 theme for LXDM"
+arch=('any')
+url="https://github.com/redtide/lxdm-theme-archlinux/"
+install=archlinux-lxdm-theme-full.install
+license=('CCPL:by-sa')
+depends=('lxdm')
+source=("git://github.com/redtide/lxdm-theme-archlinux.git")
+md5sums=('SKIP')
+
+package() {
+ install -d "$pkgdir/usr/share/lxdm/themes/Archlinux"
+ cp -r $srcdir/lxdm-theme-archlinux/Archlinux "$pkgdir/usr/share/lxdm/themes"
+}
diff --git a/archlinux-lxdm-theme-full.install b/archlinux-lxdm-theme-full.install
new file mode 100644
index 000000000000..741ff505b634
--- /dev/null
+++ b/archlinux-lxdm-theme-full.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "==> In order to activate this theme, you must edit"
+ echo " /etc/lxdm/lxdm.conf and set:"
+ echo " theme=Archlinux"
+}
+
+post_upgrade() {
+ post_install
+}