summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlastair Pharo2019-05-08 00:14:40 +1000
committerAlastair Pharo2019-05-08 00:14:40 +1000
commit4f203403e44471192bd5ece500a61b702b20e645 (patch)
tree961b9b3408a43dd7925ebf4625004259009f8135
downloadaur-4f203403e44471192bd5ece500a61b702b20e645.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59f3bc618131
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = archlinux-nix-git
+ pkgdesc = A command-line tool for setting up Nix on Arch Linux
+ pkgver = r14.b0ed00f
+ pkgrel = 1
+ url = https://github.com/asppsa/archlinux-nix
+ arch = any
+ makedepends = git
+ provides = archlinux-nix
+ conflicts = archlinux-nix
+ source = git+https://github.com/asppsa/archlinux-nix.git
+ md5sums = SKIP
+
+pkgname = archlinux-nix-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..798452743bac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74752274d704
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alastair Pharo <me at asph dot dev>
+pkgname=archlinux-nix-git
+pkgver=r14.b0ed00f
+pkgrel=1
+pkgdesc="A command-line tool for setting up Nix on Arch Linux"
+arch=('any')
+url="https://github.com/asppsa/archlinux-nix"
+licese=('Apache')
+groups=()
+depends=()
+makedepends=('git')
+provides=("archlinux-nix")
+conflicts=("archlinux-nix")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/asppsa/archlinux-nix.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}