summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannes Schulze2017-07-15 10:15:49 +0200
committerHannes Schulze2017-07-15 10:15:49 +0200
commit8abac7fa587c68323f2ac05e2179b3aeee9035d4 (patch)
treeebf45c21caeb4ae720e857ab7fe4eb145b19ef94
downloadaur-8abac7fa587c68323f2ac05e2179b3aeee9035d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83dc4c2ffeb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = archmaker
+ pkgdesc = Quickly and easily create your own arch-based GNU/Linux-distribution
+ pkgver = 0.0.1
+ pkgrel = 0
+ url = https://archmaker.guidedlinux.org/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = vte
+ depends = gtk3
+ depends = gtkmm3
+ depends = archiso
+ provides = archmaker
+ conflicts = archmaker
+ source = archmaker-0.0.1::git+https://github.com/guidedlinux/archmaker#branch=master
+ md5sums = SKIP
+
+pkgname = archmaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b42b412758ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hannes Schulze <projects@guidedlinux.org>
+pkgname=archmaker
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="Quickly and easily create your own arch-based GNU/Linux-distribution"
+arch=('x86_64')
+url="https://archmaker.guidedlinux.org/"
+license=('GPL3')
+depends=('vte' 'gtk3' 'gtkmm3' 'archiso')
+makedepends=('git')
+provides=('archmaker')
+conflicts=('archmaker')
+source=("$pkgname-$pkgver"::'git+https://github.com/guidedlinux/archmaker#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file