summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Doppler2016-03-03 11:12:14 +0100
committerSimon Doppler2016-03-03 11:12:14 +0100
commit5298969849323597ae1c757a59b7cf142ee215c4 (patch)
tree05f2afc64292dbff4722a7b03dbac20f2cd2ac44
downloadaur-5298969849323597ae1c757a59b7cf142ee215c4.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD44
-rw-r--r--archmap-git.install11
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecb09eedf979
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Mar 3 10:11:53 UTC 2016
+pkgbase = archmap-git
+ pkgdesc = Generates a map of Arch Linux users
+ pkgver = 0.3.r39.g09c5587
+ pkgrel = 1
+ url = https://github.com/maelstrom59/ArchMap
+ install = archmap-git.install
+ arch = any
+ license = custom:UNLICENSE
+ makedepends = git
+ makedepends = python-sphinx
+ depends = python-geojson
+ depends = python-simplekml
+ source = archmap::git+https://github.com/maelstrom59/ArchMap.git
+ md5sums = SKIP
+
+pkgname = archmap-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cffc5acc11a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+*.pkg.tar.xz
+src/
+*.tar.gz
+*.zip
+archmap/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34ededbb7c3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Simon Doppler <dop.simon@gmail.com>
+# Original maintainer: Johannes Löthberg <johannes@kyriasis.com>
+
+_projname=ArchMap
+pkgname=archmap-git
+pkgver=0.3.r39.g09c5587
+pkgrel=1
+
+pkgdesc="Generates a map of Arch Linux users"
+arch=('any')
+url="https://github.com/maelstrom59/ArchMap"
+license=('custom:UNLICENSE')
+
+depends=('python-geojson' 'python-simplekml')
+makedepends=('git' 'python-sphinx')
+
+install=archmap-git.install
+source=("archmap::git+https://github.com/maelstrom59/${_projname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd archmap
+ git describe --tags | sed 's/^v//; s/-/-r/; s/-/./g'
+}
+
+build() {
+ cd archmap/docs
+ make man
+}
+
+package() {
+ cd archmap
+ install -D archmap.py "$pkgdir/usr/bin/archmap"
+
+ install -d "$pkgdir/usr/lib/systemd/system"
+ install -m644 systemd/archmap.{service,timer} "$pkgdir/usr/lib/systemd/system/"
+
+ install -d "$pkgdir/usr/share/doc/archmap"
+ install {README.rst,archmap.conf} "$pkgdir/usr/share/doc/archmap"
+
+ install -D docs/_build/man/archmap.1 "$pkgdir/usr/share/man/man1/archmap.1"
+
+ install -D -m644 UNLICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/archmap-git.install b/archmap-git.install
new file mode 100644
index 000000000000..a6e70d2aa3f7
--- /dev/null
+++ b/archmap-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ cat <<EOF
+==> Copy the template config from /usr/share/doc/archmap.conf to /etc
+==> and edit the paths. Enable and start archmap.timer to generate a
+==> new map every 24 hours.
+EOF
+}
+
+post_upgrade() {
+ post_install
+}