summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-08-27 10:27:31 -0400
committerKevin MacMartin2015-08-27 10:27:31 -0400
commitd82b2e127daaea8bf77d774326c5402ab2b92c04 (patch)
tree8999454af1a49e7908d2c710c8dd668d3341768f
parentdee294633f71e14c0e718f3f826eb3f667b02150 (diff)
downloadaur-d82b2e127daaea8bf77d774326c5402ab2b92c04.tar.gz
Update all versions to 2.1.0 and add a .gitignore
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD72
3 files changed, 47 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae4b9b87b00e..edbcd08a3f79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = archon
pkgdesc = Execute Android APKs
- pkgver = 1.2
- pkgrel = 8
- url = https://bitbucket.org/vladikoff/archon
+ pkgver = 2.1.0
+ pkgrel = 9
+ url = http://archon-runtime.github.io
arch = i686
arch = x86_64
arch = armv7h
@@ -15,8 +15,10 @@ pkgbase = archon
optdepends = chromeos-apk: extract and convert android apks into archon apks
optdepends = google-chrome: run the archon extension the same as chromium
options = !strip
- source = git+https://bitbucket.org/vladikoff/archon.git#tag=v1.2-
- sha512sums = SKIP
+ source_i686 = http://archon.vf.io/ARChon-v2.1.0-x86_32.zip
+ sha512sums_i686 = 23cd42c41a6bfb2a6bffcd42efbb3f32c781609a7b4ed01c716ca817213298e0bd83550759b0e4979703d9011e40e54faf9fe8b64eba260637909dc6296f8dcc
+ source_x86_64 = https://bitbucket.org/vladikoff/archon/get/v2.1.0-x86_64.zip
+ sha512sums_x86_64 = 16ce5d52b7835e4eb755c3bd3e99db3dabdeec5f93c6812400fc25f7ff8e2be878e678f4404def3a180ec3f5354f6d5b5470832f3626d7a95efc131c80ccae5e
pkgname = archon
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9bc624a50c56
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zip
+*.pkg.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index abe0dfc0896d..21ac9803d320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Contributor: PedroHCL (https://github.com/PedroHLC)
pkgname=archon
-pkgver=1.2
-pkgrel=8
-pkgdesc="Execute Android APKs"
+pkgver=2.1.0
+pkgrel=9
+pkgdesc='Execute Android APKs'
arch=('i686' 'x86_64' 'armv7h')
-url="https://bitbucket.org/vladikoff/archon"
+url='http://archon-runtime.github.io'
license=('Apache' 'custom')
options=('!strip')
depends=('chromium')
@@ -15,50 +15,50 @@ optdepends=('archon-exec: wrapper script for launching android apk files'
'chromeos-apk: extract and convert android apks into archon apks'
'google-chrome: run the archon extension the same as chromium')
-_installpath="/opt/$pkgname"
+_installpath=/opt/$pkgname
_extension_paths=('/usr/share/chromium/extensions' '/usr/share/google-chrome/extensions')
-case $CARCH in
- i686) _tag="x86_32" ;;
- armv7h) _tag="ARM" ;;
- x86_64) _tag="$CARCH"
- pkgver=2.1.0 ;;
-esac
-_tag="v${pkgver}-${_tag}"
-source=("git+${url}.git#tag=${_tag}")
-sha512sums=('SKIP')
+source_i686=("http://archon.vf.io/ARChon-v$pkgver-x86_32.zip")
+sha512sums_i686=('23cd42c41a6bfb2a6bffcd42efbb3f32c781609a7b4ed01c716ca817213298e0bd83550759b0e4979703d9011e40e54faf9fe8b64eba260637909dc6296f8dcc')
+source_x86_64=("https://bitbucket.org/vladikoff/archon/get/v$pkgver-x86_64.zip")
+sha512sums_x86_64=('16ce5d52b7835e4eb755c3bd3e99db3dabdeec5f93c6812400fc25f7ff8e2be878e678f4404def3a180ec3f5354f6d5b5470832f3626d7a95efc131c80ccae5e')
prepare() {
- # Increase the application font size by 1.2 times (the default is a bit too small)
- sed -i 's|window\.devicePixelRatio|1\.2\*window\.devicePixelRatio|' $pkgname/gen_{index,main}.min.js
+ # Create a symlink to the archon directory with a common name
+ for dir in ./*archon*; do
+ [[ -d "$dir" ]] && ln -sf "$dir" $pkgname
+ done
+
+ # Increase the application font size by 1.2 times (the default is a bit too small)
+ sed -i 's|window\.devicePixelRatio|1\.2\*window\.devicePixelRatio|' $pkgname/gen_{index,main}.min.js
}
build() {
- # Generate the extension
- chromium --pack-extension=$pkgname
+ # Generate the extension
+ chromium --pack-extension=$pkgname
- # Write the plugin metadata file
- echo '{"external_crx": "'"$_installpath/$pkgname"'.crx", "external_version": "'"$(egrep '^\s*"version"' $pkgname/manifest.json | sed 's|^\s*"version": "||;s|",$||')"'"}' \
- > pluginid.json
+ # Write the plugin metadata file
+ printf '%s\n' '{"external_crx": "'"$_installpath/$pkgname"'.crx", "external_version": "'"$(egrep '^\s*"version"' $pkgname/manifest.json | sed 's|^\s*"version": "||;s|",$||')"'"}' \
+ > pluginid.json
}
package() {
- # Install the ARChon license files
- install -Dm644 $pkgname/NOTICE.{html,txt} -t "$pkgdir"/usr/share/licenses/$pkgname
+ # Install the ARChon license files
+ install -Dm644 $pkgname/NOTICE.{html,txt} -t "$pkgdir/usr/share/licenses/$pkgname"
- # Install the ARChon extension
- install -Dm755 ${pkgname}.crx "$pkgdir$_installpath"/${pkgname}.crx
+ # Install the ARChon extension
+ install -Dm755 $pkgname.crx "$pkgdir$_installpath/$pkgname.crx"
- # Install the ARChon app files
- cp -r --no-preserve=ownership $pkgname/* "$pkgdir$_installpath"/
+ # Install the ARChon app files
+ cp -r --no-preserve=ownership $pkgname/* "$pkgdir$_installpath"/
- # Generate the filename for the plugin metadata file using its extension id
- _extension_file="$(openssl rsa -pubout -outform DER < ${pkgname}.pem \
- | sha256sum \
- | head -c32 \
- | tr 0-9a-f a-p).json"
- # Install the plugin metadata file to each extension folder
- for _path in ${_extension_paths[@]}; do
- install -Dm644 pluginid.json "$pkgdir$_path"/$_extension_file
- done
+ # Generate the filename for the plugin metadata file using its extension id
+ _extension_file="$(openssl rsa -pubout -outform DER < ${pkgname}.pem \
+ | sha256sum \
+ | head -c32 \
+ | tr 0-9a-f a-p).json"
+ # Install the plugin metadata file to each extension folder
+ for _path in "${_extension_paths[@]}"; do
+ install -Dm644 pluginid.json "$pkgdir$_path"/$_extension_file
+ done
}