summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBiteDasher2021-01-17 18:45:12 +0300
committerBiteDasher2021-01-17 18:45:12 +0300
commit123f7cb64ac969e48c3b0cce8b66c202325d6053 (patch)
treee646d842212e0613f1cc6d5ae320a09311bc954f
downloadaur-123f7cb64ac969e48c3b0cce8b66c202325d6053.tar.gz
First release of archpxe
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1164bbe87b6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = archpxe
+ pkgdesc = About Quick setup of PXE server to load Arch Linux using an ethernet cable
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/BiteDasher/archpxe
+ arch = any
+ license = MIT
+ depends = bash
+ depends = coreutils
+ depends = grep
+ depends = dnsmasq
+ depends = darkhttpd
+ optdepends = curl: ISO download
+ source = archpxe::git+https://github.com/BiteDasher/archpxe.git
+ sha512sums = SKIP
+
+pkgname = archpxe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a22c708d07dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Author: Artemii Sudakov <finziyr@yandex.ru>
+
+pkgname="archpxe"
+pkgver="1.0"
+pkgrel="1"
+pkgdesc='About
+Quick setup of PXE server to load Arch Linux using an ethernet cable'
+arch=('any')
+url="https://github.com/BiteDasher/archpxe"
+license=('MIT')
+depends=('bash' 'coreutils' 'grep' 'dnsmasq' 'darkhttpd')
+optdepends=("curl: ISO download")
+source=("${pkgname}::git+https://github.com/BiteDasher/archpxe.git")
+sha512sums=("SKIP")
+package() {
+ install -Dm755 "$srcdir/$pkgname/archpxe" "$pkgdir/usr/bin/archpxe"
+}