summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheo J.A. de Vries2015-09-19 00:13:12 +0200
committerTheo J.A. de Vries2015-09-19 00:13:12 +0200
commit8b5d4e4cb71b7f48069aed2fdba130b2d27b113e (patch)
tree374a9048dea3c24065b3aa77ec0dd52e728cec30
downloadaur-8b5d4e4cb71b7f48069aed2fdba130b2d27b113e.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
-rw-r--r--arch.pngbin0 -> 4908 bytes
-rw-r--r--archupdate.desktop10
-rwxr-xr-xarchupdate.sh8
5 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6db444c044a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = archupdate
+ pkgdesc = A simple script to update archlinux using pacmatic and pacaur.
+ pkgver = 1
+ pkgrel = 1
+ url = http://semiletov.org/tea/
+ arch = any
+ license = Apache
+ depends = bash
+ depends = pacmatic
+ depends = pacaur
+ source = archupdate.sh
+ source = archupdate.desktop
+ source = arch.png
+ md5sums = 9647e3b024f7efafc88e771d6b31a6c7
+ md5sums = 85870d14b854b996f3a48c66db689edb
+ md5sums = f320506b8b461536febc036e6168e77a
+
+pkgname = archupdate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ebd5cde0138
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Theo J.A. de Vries <t.j.a.devries(at)gmail(dot)com>
+
+# for customization
+_pkgname=archupdate
+_ext=
+_basedir=/usr
+
+pkgname=${_pkgname}${_ext}
+pkgver=1
+pkgrel=1
+pkgdesc="A simple script to update archlinux using pacmatic and pacaur."
+arch=('any')
+url="http://semiletov.org/tea/"
+license=('Apache')
+depends=('bash' 'pacmatic' 'pacaur')
+source=(
+ archupdate.sh
+ archupdate.desktop
+ arch.png
+ )
+#md5sums=() #generate with 'makepkg -g >> PKGBUILD'
+
+build() {
+ msg "Nothing to build really.."
+}
+
+package() {
+ # cd "$srcdir/$_gitname-build"
+
+ msg "Installing script file"
+ install -Dm655 "${srcdir}/archupdate.sh" "${pkgdir}${_basedir}/bin/archupdate.sh"
+ install -Dm644 "${srcdir}/archupdate.desktop" "${pkgdir}/${_basedir}/share/applications/archupdate.desktop"
+ install -Dm644 "${srcdir}/arch.png" "${pkgdir}/${_basedir}/share/pixmaps/archicon.png"
+}
+md5sums=('9647e3b024f7efafc88e771d6b31a6c7'
+ '44e877b407ed393fe4e4fc4f1b2e73e3'
+ 'f320506b8b461536febc036e6168e77a')
+md5sums=('9647e3b024f7efafc88e771d6b31a6c7'
+ '9980b3d474c5ef5bd3f57c20dbeb748e'
+ 'f320506b8b461536febc036e6168e77a')
+md5sums=('9647e3b024f7efafc88e771d6b31a6c7'
+ '85870d14b854b996f3a48c66db689edb'
+ 'f320506b8b461536febc036e6168e77a')
diff --git a/arch.png b/arch.png
new file mode 100644
index 000000000000..a67fd35d1c22
--- /dev/null
+++ b/arch.png
Binary files differ
diff --git a/archupdate.desktop b/archupdate.desktop
new file mode 100644
index 000000000000..a068aa93ca7b
--- /dev/null
+++ b/archupdate.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=ArchUpdate
+Comment=A script for updating Arch Linux
+Exec=archupdate.sh
+Terminal=true
+Type=Application
+StartupNotify=false
+Icon=archicon.png
+Categories=Application;Utility; \ No newline at end of file
diff --git a/archupdate.sh b/archupdate.sh
new file mode 100755
index 000000000000..03df9af4c2e2
--- /dev/null
+++ b/archupdate.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+# A script for updating Archlinux using pacmatic and pacaur
+
+export pacman_program="pacaur"
+export pacdiff_program="sudo pacdiff"
+pacmatic -Syu
+read -p "Press enter to continue..."