summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGulshan Singh2015-08-30 15:48:41 -0700
committerGulshan Singh2015-08-30 15:48:41 -0700
commitdc0b2f8f110e78127ef9b3fc89c2d079ea7cbbcb (patch)
treeab8165cd7df1b14fa3f3218ab2de61cbb7d92784
downloadaur-dc0b2f8f110e78127ef9b3fc89c2d079ea7cbbcb.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..525160887f76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = archutil
+ pkgdesc = A tool for listing and backing up explicitly installed packages and for managing config files
+ pkgver = r47.e9b0dd2
+ pkgrel = 1
+ url = https://github.com/gsingh93/archutil
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = python2
+ source = git+https://github.com/gsingh93/archutil
+ md5sums = SKIP
+
+pkgname = archutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5545cf5a3d16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gulshan Singh <gsingh2011@gmail.com>
+pkgname=archutil
+pkgver=r47.e9b0dd2
+pkgrel=1
+pkgdesc="A tool for listing and backing up explicitly installed packages and for managing config files"
+arch=('i686' 'x86_64')
+url="https://github.com/gsingh93/archutil"
+license=('MIT')
+makedepends=('git')
+depends=('python2')
+source=('git+https://github.com/gsingh93/archutil')
+md5sums=('SKIP')
+
+_gitname="archutil"
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ python setup.py sdist
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}