summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Keller2015-09-28 22:54:45 +0200
committerAndre Keller2015-09-28 22:55:16 +0200
commit3fe1b588d7553d2229488b7f7cc3d3fadd53e9fa (patch)
treeade51d243701b754410c450a03242bc5b32cbd56
downloadaur-3fe1b588d7553d2229488b7f7cc3d3fadd53e9fa.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab0406529d3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = archvyrt
+ pkgdesc = libvirt provisioner for archlinux libvirt hosts
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/andrekeller/archvyrt
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-setuptools
+ depends = libvirt-python3
+ source = https://pypi.python.org/packages/source/a/archvyrt/archvyrt-0.1.1.tar.gz
+ md5sums = 20ceeef7e8278222f2ea3be72925c2aa
+
+pkgname = archvyrt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eea7ff7d802a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=archvyrt
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="libvirt provisioner for archlinux libvirt hosts"
+url="https://github.com/andrekeller/archvyrt"
+depends=('python' 'python-setuptools' 'libvirt-python3')
+makedepends=('python-setuptools' )
+license=('MIT')
+arch=('any')
+source=('https://pypi.python.org/packages/source/a/archvyrt/archvyrt-0.1.1.tar.gz')
+md5sums=('20ceeef7e8278222f2ea3be72925c2aa')
+
+build() {
+ cd $srcdir/archvyrt-0.1.1
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/archvyrt-0.1.1
+ python setup.py install --root="$pkgdir" --optimize=1
+}