summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:21:50 +0200
committerM0Rf302015-06-17 15:21:50 +0200
commit1c8dcdedfca6a26de49b2dda5896369f485414cc (patch)
tree07fe92ad1dcdc6367df050cd74216096b57ca615
downloadaur-1c8dcdedfca6a26de49b2dda5896369f485414cc.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
-rw-r--r--archweb-git.install22
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca115a6d0991
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = archweb-git
+ pkgdesc = Arch website code
+ pkgver = 1911.ffaa2cf
+ pkgrel = 1
+ url = http://projects.archlinux.org/archweb.git/
+ install = archweb-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python2-django
+ depends = python2-south
+ depends = python2-bencode
+ depends = python2-memcached
+ depends = python2-pyinotify
+ depends = python2-psycopg2
+ depends = python2-markdown
+ depends = python2-pytz
+ depends = pgpdump-git
+ source = archweb::git://projects.archlinux.org/archweb.git
+ md5sums = SKIP
+
+pkgname = archweb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cef4f1fb3653
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: M0Rf30
+
+pkgname=archweb-git
+pkgver=1911.ffaa2cf
+pkgrel=1
+pkgdesc="Arch website code"
+arch=('i686' 'x86_64')
+url="http://projects.archlinux.org/archweb.git/"
+license=('GPL')
+depends=('python2-django' 'python2-south' 'python2-bencode' 'python2-memcached' 'python2-pyinotify' 'python2-psycopg2' 'python2-markdown' 'python2-pytz' 'pgpdump-git')
+makedepends=('git')
+install=$pkgname.install
+source=('archweb::git://projects.archlinux.org/archweb.git')
+
+package() {
+ mkdir -p $pkgdir/srv/http
+ cp -r archweb $pkgdir/srv/http/
+ rm -r $pkgdir/srv/http/archweb/.git*
+}
+
+pkgver() {
+ cd archweb
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')
diff --git a/archweb-git.install b/archweb-git.install
new file mode 100644
index 000000000000..35761422b055
--- /dev/null
+++ b/archweb-git.install
@@ -0,0 +1,22 @@
+
+post_install() {
+
+echo "1. Copy local_settings.py.example to local_settings.py and modify."
+echo " Make sure to uncomment the appropriate db section (either sqlite or mysql)."
+echo ""
+echo " 2. Sync the database to create it."
+echo " $ python manage.py syncdb"
+echo ""
+echo " 3. Load the fixtures to prepopulate some data."
+echo " $ python manage.py loaddata arches.json repos.json"
+echo ""
+echo " 4. Use the following commands to start a service instance"
+echo " $ python manage.py runserver"
+echo ""
+echo " 5. To optionally populate the database with real data:"
+echo " $ wget ftp://ftp.archlinux.org/core/os/i686/core.db.tar.gz"
+echo " $ scripts/reporead.py i686 ./core.db.tar.gz"
+echo ""
+echo " (alter architecture and repo to get x86_64 and extra packages if needed)"
+}
+