summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopcorn2018-11-25 07:44:30 +0800
committerPopcorn2018-11-25 07:44:30 +0800
commitf62b48c3a3fc5edcee0bf7ffa9aa5d497c8a972a (patch)
tree47548a6dac1448665c70d6589d1f4d51b5b506d4
parentdef0f63a846bdbb1f60ae7d4af8cb4c12e0f2a9e (diff)
downloadaur-f62b48c3a3fc5edcee0bf7ffa9aa5d497c8a972a.tar.gz
20181125
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8259d9c74a1..7a38a4db7702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = arcint-gtk-theme
pkgdesc = My own version of horst3180's Arc theme
- pkgver = 20181121
+ pkgver = 20181125
pkgrel = 1
- url = https://gitgud.io/popcorn/arcint-theme
+ url = https://gitgud.io/popcorn/arcint-gtk-theme
arch = any
license = GPL3
makedepends = gtk3
@@ -12,8 +12,8 @@ pkgbase = arcint-gtk-theme
optdepends = gnome-themes-standard: for gtk2 themes
provides = arcint-gtk-theme
conflicts = arcint-gtk-theme-git
- source = https://gitgud.io/popcorn/arcint-theme/-/archive/20181121/arcint-theme-20181121.tar.gz
- sha512sums = abdf298514c1ad80e90cca2d9235ba052f6f1a8ee15ab041c396e726e339aebd6c275d6856b5e7f5627420cafdd35ed30efd0a152a07a7d6321c6754bf3f72fa
+ source = https://gitgud.io/popcorn/arcint-gtk-theme/-/archive/20181125/arcint-gtk-theme-20181125.tar.gz
+ sha512sums = b2113abda1f960aa2a2bb64de80cf2ee8c90e235046573bf4fce3d75303859f73c3f35839a5279774242edf0aea6754449d699c730cb41d23ee94798d0e4de21
pkgname = arcint-gtk-theme
diff --git a/PKGBUILD b/PKGBUILD
index a67301b70707..2fdb439f9a66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: Popcorn <popcorn-public {at} protonmail {dot} com>
pkgname=arcint-gtk-theme
-_pkgname=arcint-theme
pkgdesc="My own version of horst3180's Arc theme"
-pkgver=20181121
+pkgver=20181125
pkgrel=1
arch=("any")
provides=("arcint-gtk-theme")
conflicts=("arcint-gtk-theme-git")
-url="https://gitgud.io/popcorn/arcint-theme"
+url="https://gitgud.io/popcorn/arcint-gtk-theme"
license=("GPL3")
optdepends=("gnome-themes-standard: for gtk2 themes")
makedepends=("gtk3" "sassc" "optipng" "inkscape")
-source=("${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha512sums=("abdf298514c1ad80e90cca2d9235ba052f6f1a8ee15ab041c396e726e339aebd6c275d6856b5e7f5627420cafdd35ed30efd0a152a07a7d6321c6754bf3f72fa")
+source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=("b2113abda1f960aa2a2bb64de80cf2ee8c90e235046573bf4fce3d75303859f73c3f35839a5279774242edf0aea6754449d699c730cb41d23ee94798d0e4de21")
build() {
- cd "${_pkgname}-${pkgver}"
- ./autogen.sh --prefix=/usr
+ "${pkgname}-${pkgver}/make.sh" --prefix="${srcdir}/build"
}
package() {
- make -C "${srcdir}/${_pkgname}-${pkgver}" DESTDIR="${pkgdir}" install
+ mv "${srcdir}/build" "${pkgdir}/usr"
}