summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPOPCORNS2018-09-05 23:16:53 +0800
committerPOPCORNS2018-09-05 23:16:53 +0800
commit7d865755e9fa2595569b6c384ac2db5446423464 (patch)
tree818418ed27aacb2ecae4fb03980b7f8be92e3e09
downloadaur-7d865755e9fa2595569b6c384ac2db5446423464.tar.gz
Upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c7da2f702a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = arcint-gtk-theme-git
+ pkgdesc = My own version of horst3180's Arc theme
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitgud.io/popcorns/arcint-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = gtk3
+ makedepends = sassc
+ makedepends = optipng
+ makedepends = inkscape
+ optdepends = gnome-themes-standard: for gtk2 themes
+
+pkgname = arcint-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c81c5f3ea590
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: POPCORNS <archlinux {at} protonmail {dot} com>
+
+pkgname=arcint-gtk-theme-git
+_pkgname=arcint-theme
+pkgdesc="My own version of horst3180's Arc theme"
+pkgver=1.0
+pkgrel=1
+arch=("any")
+url="https://gitgud.io/popcorns/arcint-theme"
+license=("GPL3")
+optdepends=("gnome-themes-standard: for gtk2 themes")
+makedepends=("git" "gtk3" "sassc" "optipng" "inkscape")
+
+pkgver() {
+ date +%Y%m%d
+}
+
+prepare() {
+ git clone --depth 1 ${url}
+}
+
+build() {
+ cd ${_pkgname}
+ ./autogen.sh --prefix=/usr
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+}