summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorautinerd2023-10-29 17:54:48 +0100
committerautinerd2023-10-29 17:54:48 +0100
commitc1ad77e7ae0d62347e3e57e7c4a26e3e29b42c58 (patch)
tree5600b1ba6375114e7009344b5f2c056cd79f561d
parent635ced19af81c618077d3e61a2108157a7f0b3ea (diff)
downloadaur-c1ad77e7ae0d62347e3e57e7c4a26e3e29b42c58.tar.gz
new structure of upstream repo
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
2 files changed, 9 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2913817cd8f..370f2fb12b93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = arcticons-icon-theme-git
pkgdesc = A monotone line-based icon pack for android - freedesktop version (git version)
- pkgver = 7.3.7.r0.g844f78947
+ pkgver = r31.a18d75e
pkgrel = 1
- url = https://github.com/Donnnno/Arcticons
+ url = https://github.com/Donnnno/Arcticons-Linux
arch = any
license = GPL3
- optdepends = inkscape: for generating the symbolic icons
provides = arcticons-icon-theme
conflicts = arcticons-icon-theme
options = !strip
- source = git+https://github.com/Donnnno/Arcticons.git
+ source = git+https://github.com/Donnnno/Arcticons-Linux.git
sha512sums = SKIP
pkgname = arcticons-icon-theme-git
diff --git a/PKGBUILD b/PKGBUILD
index 1f8bf6b9b69f..7ed4852a3005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,26 @@
# Maintainer: autinerd <autinerd-arch at kuyateh dot eu>
pkgname=arcticons-icon-theme-git
-pkgver=7.3.7.r0.g844f78947
+pkgver=r31.a18d75e
pkgrel=1
pkgdesc='A monotone line-based icon pack for android - freedesktop version (git version)'
arch=('any')
-optdepends=('inkscape: for generating the symbolic icons')
-url='https://github.com/Donnnno/Arcticons'
+url='https://github.com/Donnnno/Arcticons-Linux'
license=('GPL3')
options=(!strip)
provides=('arcticons-icon-theme')
conflicts=('arcticons-icon-theme')
-source=('git+https://github.com/Donnnno/Arcticons.git')
+source=('git+https://github.com/Donnnno/Arcticons-Linux.git')
sha512sums=('SKIP')
pkgver() {
- cd "${srcdir}/Arcticons"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- cd "$srcdir/Arcticons/freedesktop-theme"
- rm -rf arcticons-dark arcticons-light || true
- ./generate.sh white 2
- mv arcticons arcticons-dark
- sed -e s/Arcticons/Arcticons-dark/g -e s/breeze/breeze-dark/g index.theme > arcticons-dark/index.theme
- ./generate.sh black 2
- mv arcticons arcticons-light
- rm arcticons.tar.gz
+ cd "${srcdir}/Arcticons-Linux"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
package() {
- cd "$srcdir/Arcticons/freedesktop-theme"
+ cd "$srcdir/Arcticons-Linux"
install -d "$pkgdir/usr/share/icons"
cp -r arcticons-light arcticons-dark "$pkgdir/usr/share/icons"
- cd "$srcdir/Arcticons"
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}