summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqaz2019-04-11 22:32:03 +0800
committerqaz2019-04-11 22:32:03 +0800
commitfe31bcbd572f0e20218dbc3c46c823a764cb38f7 (patch)
tree65294724feb5be4444031d112ee58342383bc898
downloadaur-fe31bcbd572f0e20218dbc3c46c823a764cb38f7.tar.gz
create arctime
-rw-r--r--.SRCINFO26
-rw-r--r--16x16.pngbin0 -> 584 bytes
-rw-r--r--24x24.pngbin0 -> 956 bytes
-rw-r--r--32x32.pngbin0 -> 1541 bytes
-rw-r--r--48x48.pngbin0 -> 2326 bytes
-rw-r--r--PKGBUILD62
-rw-r--r--arctime.desktop16
7 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa27ce5df06d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = arctime
+ pkgdesc = A Simple, powerful and efficient cross-platform subtitle production software
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://arctime.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = ffmpeg
+ depends = java-runtime=8
+ depends = vlc
+ source = https://dl.arctime.cn/Arctime2.2.1/ARCTIME_PRO_2.2.1_LINUX.7z
+ source = 16x16.png
+ source = 24x24.png
+ source = 32x32.png
+ source = 48x48.png
+ source = arctime.desktop
+ sha256sums = 623bd4fec7b13f99320e6d7fcfb3458010294946ea2481c2b3b54bec3d8c841c
+ sha256sums = 9f490a4fc4d4f15e31b15e84717e11ce794e908055484f22d02aa0a166093677
+ sha256sums = 406a3953b7b5d54814f6613f23badc0eff04909688d67295371aeeead862ae85
+ sha256sums = fcd6ecf0a786658968d0c8747b860b5238c0df73c873642dd7ce5fca186d2122
+ sha256sums = c9bc9ac2ffdc703b672c1f918ea4d48479693bdc69dfd346a077547de47ce7d1
+ sha256sums = 234004078ed6b0ab0e46905fa7a259c7e0a7da971012e0692cccaff96882df8a
+
+pkgname = arctime
+
diff --git a/16x16.png b/16x16.png
new file mode 100644
index 000000000000..4af2aaf18e0f
--- /dev/null
+++ b/16x16.png
Binary files differ
diff --git a/24x24.png b/24x24.png
new file mode 100644
index 000000000000..944435edbb2b
--- /dev/null
+++ b/24x24.png
Binary files differ
diff --git a/32x32.png b/32x32.png
new file mode 100644
index 000000000000..bd42d99a66cc
--- /dev/null
+++ b/32x32.png
Binary files differ
diff --git a/48x48.png b/48x48.png
new file mode 100644
index 000000000000..856ff95b4648
--- /dev/null
+++ b/48x48.png
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eedbbd0e35a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: qaz <fkxxyz@163.com>
+# Contributor: qaz <fkxxyz@163.com>
+
+pkgname=arctime
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="A Simple, powerful and efficient cross-platform subtitle production software"
+arch=("i686" "x86_64")
+url="http://arctime.org"
+license=('custom')
+depends=('ffmpeg' 'java-runtime=8' 'vlc')
+source=(
+ "https://dl.arctime.cn/Arctime2.2.1/ARCTIME_PRO_2.2.1_LINUX.7z"
+ 16x16.png
+ 24x24.png
+ 32x32.png
+ 48x48.png
+ arctime.desktop
+)
+
+package() {
+ for png in *.png; do
+ install -D ./${png} "${pkgdir}/usr/share/icons/hicolor/${png%.*}/apps/${pkgname}.png"
+ done
+
+ install -D ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -d "${pkgdir}/usr/share/licenses/$pkgname"
+ touch "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+
+ cd ${srcdir}/ARCTIME_PRO_${pkgver}_LINUX
+ pkghome="${pkgdir}/usr/share/${pkgname}"
+ install -Dm644 ./ArcTime.jar "${pkghome}/ArcTime.jar"
+ cp -r ./ArcTime_lib "${pkghome}/ArcTime_lib"
+ cp -r ./resources "${pkghome}/resources"
+ chmod 644 "${pkghome}/resources/Roboto-Regular.ttf"
+ install -d "${pkghome}/tools/config"
+ echo '/usr/lib' > "${pkghome}/tools/config/vlcpath.txt"
+ install -d "${pkghome}/tools/"{x86,x64}
+ ln -sf /usr/bin/ffmpeg "${pkghome}/tools/x86/ffmpeg-linux32"
+ ln -sf /usr/bin/ffprobe "${pkghome}/tools/x86/ffprobe-linux32"
+ ln -sf /usr/bin/ffmpeg "${pkghome}/tools/x64/ffmpeg-linux64"
+ ln -sf /usr/bin/ffprobe "${pkghome}/tools/x64/ffprobe-linux64"
+
+ echo '#!/bin/bash
+PATH=/usr/lib/jvm/java-8-openjdk/jre/bin:$PATH
+cd /usr/share/arctime
+exec java -Xms128m -Xmx512m -jar ./ArcTime.jar
+' > "${pkghome}/$pkgname"
+ chmod +x "${pkghome}/$pkgname"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -sf "/usr/share/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et:
+sha256sums=('623bd4fec7b13f99320e6d7fcfb3458010294946ea2481c2b3b54bec3d8c841c'
+ '9f490a4fc4d4f15e31b15e84717e11ce794e908055484f22d02aa0a166093677'
+ '406a3953b7b5d54814f6613f23badc0eff04909688d67295371aeeead862ae85'
+ 'fcd6ecf0a786658968d0c8747b860b5238c0df73c873642dd7ce5fca186d2122'
+ 'c9bc9ac2ffdc703b672c1f918ea4d48479693bdc69dfd346a077547de47ce7d1'
+ '234004078ed6b0ab0e46905fa7a259c7e0a7da971012e0692cccaff96882df8a')
diff --git a/arctime.desktop b/arctime.desktop
new file mode 100644
index 000000000000..18c00b98aecf
--- /dev/null
+++ b/arctime.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Version=2.2.1
+Name=Arctime subtitle
+GenericName=subtitle
+Comment=Run Arctime, Make subtitling a pleasure
+Name[zh_CN]=Arctime 字幕制作
+GenericName[zh_CN]=字幕制作
+Comment[zh_CN]=启动 Arctime,让做字幕变成一种享受
+Name[zh_TW]=Arctime 字幕製作
+GenericName[zh_TW]=字幕製作
+Comment[zh_TW]=啓動 Arctime,讓做字幕變成一種享受
+Exec=/usr/share/arctime/arctime
+Type=Application
+StartupNotify=true
+Icon=arctime
+Categories=AudioVideo;Player;Recorder;