summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-08-22 16:59:06 +0100
committerGrey Christoforo2015-08-22 16:59:06 +0100
commit8e26410d2939a3ef383f1c23d3cae71cc9c465a8 (patch)
tree18a406e9ef13a6d6bdae4b8605c304b959826c63
parentcb6d30fdba6c627994c67ddb76c5ae060a393907 (diff)
downloadaur-8e26410d2939a3ef383f1c23d3cae71cc9c465a8.tar.gz
bump to 15.06.03
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b46518a8122..8bfe2e829a12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = arcus
pkgdesc = Communication library between internal components for Ultimaker software
- pkgver = 15.06.02
- pkgrel = 2
+ pkgver = 15.06.03
+ pkgrel = 1
url = https://github.com/Ultimaker/libArcus
arch = any
license = GPLv3
makedepends = cmake
- depends = protobuf3
- source = https://github.com/Ultimaker/libArcus/archive/master.zip
- md5sums = 781f2bd61d652335a26d7f7a17393d29
+ depends = protobuf-ultimaker
+ source = https://github.com/Ultimaker/libArcus/archive/15.06.03.tar.gz
+ md5sums = c61fafaa82f71cef5e0f6780688f853e
pkgname = arcus
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4552cbc6889a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 92c2114c2fd1..f28dab8faa71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
-# Maintainer: Grey Christoforo <grey[at]christoforo[dot]net>
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
pkgname=arcus
-pkgver=15.06.02
-pkgrel=2
+pkgver=15.06.03
+pkgrel=1
pkgdesc="Communication library between internal components for Ultimaker software"
url="https://github.com/Ultimaker/libArcus"
arch=('any')
license=('GPLv3')
makedepends=('cmake')
-depends=('protobuf3')
-conflicts=()
-replaces=()
-backup=()
-#install='foo.install'
-source=("https://github.com/Ultimaker/libArcus/archive/master.zip")
-md5sums=('781f2bd61d652335a26d7f7a17393d29')
+depends=('protobuf-ultimaker')
+source=(https://github.com/Ultimaker/libArcus/archive/${pkgver}.tar.gz)
+md5sums=('c61fafaa82f71cef5e0f6780688f853e')
build() {
- cd "${srcdir}/libArcus-master"
+ cd libArcus-${pkgver}
mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
@@ -24,7 +21,7 @@ build() {
}
package() {
- cd "${srcdir}/libArcus-master/build"
+ cd libArcus-${pkgver}/build
make DESTDIR="${pkgdir}" install
mv ${pkgdir}/usr/lib64 ${pkgdir}/usr/lib
#install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"