summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-05-24 13:09:43 +0100
committerGrey Christoforo2016-05-24 13:09:43 +0100
commit9459f3c3e9e52fe6c6e2e8b79af7c989f700e9a4 (patch)
tree46562238e7296df8ab1c134434accbabe90a067c
parentfd4b6579427c044af9b0ab0f857f5a8a6e0f0c5e (diff)
downloadaur-9459f3c3e9e52fe6c6e2e8b79af7c989f700e9a4.tar.gz
pre-release for 2.1.0
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c02fd9a75b4f..5d7a8f5a896f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=arcus
-pkgver=15.06.03
+pkgver=2.1.0
+_pkgver=cf2a4c25d67a0f8d470c333624306e3f88b120b1
pkgrel=1
pkgdesc="Communication library between internal components for Ultimaker software"
url="https://github.com/Ultimaker/libArcus"
@@ -9,11 +10,13 @@ arch=('i686' 'x86_64')
license=('GPLv3')
makedepends=('cmake' 'python')
depends=('protobuf3' 'python-protobuf3')
-source=(https://github.com/Ultimaker/libArcus/archive/${pkgver}.tar.gz)
-md5sums=('c61fafaa82f71cef5e0f6780688f853e')
+#source=(https://github.com/Ultimaker/libArcus/archive/cf2a4c25d67a0f8d470c333624306e3f88b120b1.zip)
+source=(https://github.com/Ultimaker/libArcus/archive/${_pkgver}.tar.gz)
+
+md5sums=('d33a765e9d65fdfd0c37a8e40d4ef819')
build() {
- cd libArcus-${pkgver}
+ cd libArcus-${_pkgver}
mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_EXAMPLES=OFF
@@ -21,15 +24,15 @@ build() {
}
package() {
- cd libArcus-${pkgver}/build
+ cd libArcus-${_pkgver}/build
SITE_PACKAGES=$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
make DESTDIR="${pkgdir}" install
- mv "${pkgdir}"/usr/lib64/* "${pkgdir}"/usr/lib/.
- rm -rf "${pkgdir}/usr/lib64"
+ #mv "${pkgdir}"/usr/lib64/* "${pkgdir}"/usr/lib/.
+ #rm -rf "${pkgdir}/usr/lib64"
mkdir -p "${pkgdir}${SITE_PACKAGES}"
mv "${pkgdir}"/usr/lib/python3/dist-packages/* "${pkgdir}${SITE_PACKAGES}"/.
rm -rf "${pkgdir}"/usr/lib/python3
- #install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 "$srcdir/libArcus-${_pkgver}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: