summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortetov2019-01-17 16:25:16 +0100
committertetov2019-01-17 16:25:16 +0100
commit48a85d2faf141dcf2890d69e241bc984260020e3 (patch)
treec5d39bedad8638a09a60ee838e85d86500840583
downloadaur-48a85d2faf141dcf2890d69e241bc984260020e3.tar.gz
Initial upload: arcus-beta-git 4.0-1
Name change and maintainer change
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71c34289983c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = arcus-beta-git
+ pkgdesc = Communication library between internal components for Ultimaker software
+ pkgver = 4.0
+ pkgrel = 1
+ url = https://github.com/Ultimaker/libArcus
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = sip
+ depends = python
+ depends = protobuf
+ depends = python-sip
+ conflicts = arcus
+ conflicts = libarcus-git
+ source = git+https://github.com/Ultimaker/libArcus#branch=4.0
+ md5sums = SKIP
+
+pkgname = arcus-beta-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..392490e487a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Anton T Johansson <anton@tetov.se>
+# Contributor: GPereira
+# Contributor: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=arcus-beta-git
+pkgver=4.0
+pkgrel=1
+pkgdesc="Communication library between internal components for Ultimaker software"
+url="https://github.com/Ultimaker/libArcus"
+arch=('x86_64')
+license=('LGPL3')
+conflicts=('arcus' 'libarcus-git')
+makedepends=('cmake' 'sip')
+depends=('python' 'protobuf' 'python-sip')
+source=("git+https://github.com/Ultimaker/libArcus#branch=${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd libArcus
+ mkdir -p build
+ cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_EXAMPLES=OFF \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib/
+
+ make
+}
+
+package() {
+ cd libArcus/build
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: