summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriele Musco2018-06-02 23:55:53 +0200
committerGabriele Musco2018-06-02 23:55:53 +0200
commitfac4412954b18ab8b9283e45e5d40887576f1390 (patch)
treef0a043fcfbb4895e22a0e97a73b65028f65afd6f
downloadaur-fac4412954b18ab8b9283e45e5d40887576f1390.tar.gz
first release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cf8cf3fe8c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ardhue-git
+ pkgdesc = Interface to control ArdHue Arduino based digital RGB system
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/gabmus/ardhue
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = python-serial
+ depends = gtk3>=3.14
+ depends = python
+ provides = ardhue
+ conflicts = ardhue
+ source = ardhue::git+https://github.com/gabmus/ardhue
+ sha256sums = SKIP
+
+pkgname = ardhue-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ac0052c00ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gabriele Musco <emaildigabry@gmail.com>
+# Upstream URL: https://github.com/gabmus/razercommander
+
+pkgname=ardhue-git
+pkgver=0.1
+pkgrel=1
+pkgdesc='Interface to control ArdHue Arduino based digital RGB system'
+arch=('any')
+url='https://github.com/gabmus/ardhue'
+license=('GPL3')
+depends=('python-serial' 'gtk3>=3.14' 'python')
+makedepends=('git' 'meson')
+provides=('ardhue')
+conflicts=('ardhue')
+source=("ardhue::git+https://github.com/gabmus/ardhue")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ardhue"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/ardhue"
+ rm -rf build
+ mkdir build
+ cd build
+ meson --prefix /usr --buildtype release ..
+ ninja
+}
+
+package() {
+ cd "$srcdir/ardhue"
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}