summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiels Martignène2015-06-10 10:02:44 +0200
committerNiels Martignène2015-06-10 10:02:44 +0200
commitace3d0885bd11fe543c0ea3f66edd689fd432527 (patch)
tree2dbeb7267c63a08275d6b8162fa7f2026ad14a05
downloadaur-ace3d0885bd11fe543c0ea3f66edd689fd432527.tar.gz
Initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD55
-rw-r--r--arduino.desktop11
-rw-r--r--arduino.install15
-rw-r--r--arduino.xml44
5 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..307fdbca0d74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = arduino
+ pkgdesc = Arduino prototyping platform SDK
+ pkgver = 1.6.4
+ pkgrel = 2
+ epoch = 1
+ url = http://arduino.cc/en/Main/Software
+ install = arduino.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = icoutils
+ depends = gtk2
+ depends = libusb-compat
+ depends = java-runtime
+ depends = desktop-file-utils
+ depends = libtinfo
+ depends = giflib
+ options = !strip
+ options = staticlibs
+ source = arduino.desktop
+ source = arduino.xml
+ sha256sums = d817829bb2830cb690ed63f14d8a990bb513bef4a4ebc6227a82abdfc8bcd35d
+ sha256sums = 473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68
+ source_i686 = http://downloads.arduino.cc/arduino-1.6.4-linux32.tar.xz
+ sha256sums_i686 = c30e6d681bb8d70c468b2110919ee99689668c8ca3af83a5bd0005934c761466
+ source_x86_64 = http://downloads.arduino.cc/arduino-1.6.4-linux64.tar.xz
+ sha256sums_x86_64 = eb9f2dae8b2cd131e9744eb9385af7a765888cb17916e0163ce171124546495c
+
+pkgname = arduino
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44fda2d90d96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Niels Martignène <niels.martignene@gmail.com>
+# Contributor: PyroPeter <googlemail.com@abi1789>
+# Contributor: darkapex <me@jailuthra.in>
+# Contributor: tty0 <vt.tty0[d0t]gmail.com>
+
+pkgname=arduino
+epoch=1
+pkgver=1.6.4
+pkgrel=2
+pkgdesc="Arduino prototyping platform SDK"
+arch=('i686' 'x86_64')
+url="http://arduino.cc/en/Main/Software"
+options=(!strip staticlibs)
+license=('GPL' 'LGPL')
+depends=('gtk2' 'libusb-compat' 'java-runtime' 'desktop-file-utils' 'libtinfo' 'giflib')
+makedepends=('icoutils')
+install="arduino.install"
+source=('arduino.desktop'
+ 'arduino.xml')
+source_i686+=("http://downloads.arduino.cc/arduino-${pkgver}-linux32.tar.xz")
+source_x86_64+=("http://downloads.arduino.cc/arduino-${pkgver}-linux64.tar.xz")
+sha256sums=('d817829bb2830cb690ed63f14d8a990bb513bef4a4ebc6227a82abdfc8bcd35d'
+ '473b82156505e9bd903e4d8484e8d183f2e3bf3c1f7e29940b815929ae597b68')
+sha256sums_i686=('c30e6d681bb8d70c468b2110919ee99689668c8ca3af83a5bd0005934c761466')
+sha256sums_x86_64=('eb9f2dae8b2cd131e9744eb9385af7a765888cb17916e0163ce171124546495c')
+
+build() {
+ cd "arduino-${pkgver}"
+
+ icotool -x -o .. lib/arduino_icon.ico
+}
+
+package() {
+ cd "arduino-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/"{doc,applications,mime/packages}
+
+ # copy the whole SDK to /usr/share/arduino/
+ cp -a . "${pkgdir}/usr/share/arduino"
+
+ # at least support the FHS a little bit
+ ln -s /usr/share/arduino/arduino "${pkgdir}/usr/bin/arduino"
+ ln -s /usr/share/arduino/reference "${pkgdir}/usr/share/doc/arduino"
+
+ # desktop icon
+ for size in 16 32 48 256; do
+ install -Dm644 ../arduino_icon_*_${size}x${size}x32.png \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/arduino.png"
+ done
+
+ # desktop and mimetype files
+ install -m644 "${srcdir}/arduino.desktop" "${pkgdir}/usr/share/applications/"
+ install -m644 "${srcdir}/arduino.xml" "${pkgdir}/usr/share/mime/packages/"
+}
diff --git a/arduino.desktop b/arduino.desktop
new file mode 100644
index 000000000000..180dea615bf5
--- /dev/null
+++ b/arduino.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Arduino
+GenericName=Arduino IDE
+Comment=The open-source Arduino environment
+TryExec=arduino
+Exec=arduino %U
+Icon=arduino
+Type=Application
+Terminal=false
+MimeType=text/x-arduino;
+Categories=Development;
diff --git a/arduino.install b/arduino.install
new file mode 100644
index 000000000000..b4c07efb79e5
--- /dev/null
+++ b/arduino.install
@@ -0,0 +1,15 @@
+post_upgrade() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+ update-mime-database /usr/share/mime >/dev/null
+}
+
+post_install() {
+ post_upgrade
+
+ echo "Don't forget to add yourself to the uucp and lock groups: gpasswd -a <user> uucp && gpasswd -a <user> lock (execute as root)"
+}
+
+post_remove() {
+ post_upgrade
+}
diff --git a/arduino.xml b/arduino.xml
new file mode 100644
index 000000000000..166b5a245f30
--- /dev/null
+++ b/arduino.xml
@@ -0,0 +1,44 @@
+<?xml version='1.0' encoding='utf-8'?>
+<!-- Copied from the Ubuntu package -->
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="text/x-arduino">
+ <comment>Arduino source code</comment>
+ <comment xml:lang="ara">شفرة مصدر Arduino</comment>
+ <comment xml:lang="be@latin">Kryničny kod Arduino</comment>
+ <comment xml:lang="bg">Изходен код на Arduino</comment>
+ <comment xml:lang="ca">codi font en Arduino</comment>
+ <comment xml:lang="da">Arduinokildekode</comment>
+ <comment xml:lang="de">Arduino-Quelltext</comment>
+ <comment xml:lang="el">πηγαίος κώδικας Arduino</comment>
+ <comment xml:lang="en_GB">Arduino source code</comment>
+ <comment xml:lang="eo">Arduino-fontkodo</comment>
+ <comment xml:lang="es">código fuente en Arduino</comment>
+ <comment xml:lang="eu">Arduino iturburu-kodea</comment>
+ <comment xml:lang="fi">Arduino-lähdekoodi</comment>
+ <comment xml:lang="fr">code source Arduino</comment>
+ <comment xml:lang="ga">cód foinseach Arduino</comment>
+ <comment xml:lang="hu">Arduino-forráskód</comment>
+ <comment xml:lang="id">Kode program Arduino</comment>
+ <comment xml:lang="it">Codice sorgente Arduino</comment>
+ <comment xml:lang="ja">Arduino ソースコード</comment>
+ <comment xml:lang="lt">Arduino pradinis kodas</comment>
+ <comment xml:lang="lv">Arduino pirmkods</comment>
+ <comment xml:lang="ms">Kod sumber Arduino</comment>
+ <comment xml:lang="nb">Arduino-kildekode</comment>
+ <comment xml:lang="nl">Arduino-broncode</comment>
+ <comment xml:lang="nn">Arduino-kjeldekode</comment>
+ <comment xml:lang="pl">Kod źródłowy Arduino</comment>
+ <comment xml:lang="pt">código fonte Arduino</comment>
+ <comment xml:lang="pt_BR">Código fonte Arduino</comment>
+ <comment xml:lang="ru">исходный код Arduino</comment>
+ <comment xml:lang="sq">Kod burues Arduino</comment>
+ <comment xml:lang="sv">Arduino-källkod</comment>
+ <comment xml:lang="uk">Вихідний код на мові Arduino</comment>
+ <comment xml:lang="vi">Mã nguồn Arduino</comment>
+ <comment xml:lang="zh_CN">Arduino 源代码</comment>
+ <comment xml:lang="zh_TW">Arduino 源代碼</comment>
+ <sub-class-of type="text/x-c++src"/>
+ <glob pattern="*.ino"/>
+ <glob pattern="*.pde"/>
+ </mime-type>
+</mime-info>