summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicoHood2016-11-24 19:00:32 +0100
committerNicoHood2016-11-24 19:00:32 +0100
commite7da076fac0bc1ddafc422eb2f4a1b5c3be0ef93 (patch)
tree153a3ade97366dd491cea4a17eb6d1017f84b4d1
parent0c72dd8b6d99bd9713b71411ef229d7597b42b0b (diff)
downloadaur-e7da076fac0bc1ddafc422eb2f4a1b5c3be0ef93.tar.gz
Fixed version
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2e04f854de5..16f3490febef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = arduino
pkgdesc = Arduino prototyping platform SDK
pkgver = 1.6.12
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = https://github.com/arduino/Arduino
install = arduino.install
arch = i686
arch = x86_64
- arch = armv6h
- arch = armv7h
license = GPL
license = LGPL
makedepends = java-environment=8
@@ -21,8 +19,9 @@ pkgbase = arduino
depends = arduino-builder
optdepends = arduino-docs: Offline documentation for arduino
optdepends = arduino-avr-core: AVR core with upstream avr-gcc and avrdude
+ optdepends = python2: Intel Galileo Board installation
options = !strip
- source = https://github.com/arduino/Arduino/archive/1.6.12.tar.gz
+ source = arduino-1.6.12.tar.gz::https://github.com/arduino/Arduino/archive/1.6.12.tar.gz
source = https://github.com/arduino-libraries/WiFi101-FirmwareUpdater-Plugin/releases/download/v0.8.0/WiFi101-Updater-ArduinoIDE-Plugin-0.8.0.zip
source = https://downloads.arduino.cc/libastylej-2.05.1-3.zip
source = https://downloads.arduino.cc/liblistSerials/liblistSerials-1.1.4.zip
diff --git a/PKGBUILD b/PKGBUILD
index aff73984c75b..927e165eb600 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: NicoHood <aur {at} nicohood {dot} de>
+# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
# Contributor: Tomas Schertel <tschertel at gmail dot com>
# Contributor: Christopher Loen <christopherloen at gmail dot com>
# Contributor: Peter Reschenhofer <peter.reschenhofer@gmail.com>
@@ -9,19 +10,20 @@
pkgname=arduino
pkgver=1.6.12
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc="Arduino prototyping platform SDK"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h') # TODO remove arm once moved into community
+arch=('i686' 'x86_64')
url="https://github.com/arduino/Arduino"
license=('GPL' 'LGPL')
depends=('gtk2' 'desktop-file-utils' 'shared-mime-info' 'java-runtime=8' 'arduino-builder')
makedepends=('java-environment=8' 'apache-ant' 'unzip') # TODO remove unzip once all deps are resolved
optdepends=('arduino-docs: Offline documentation for arduino'
- 'arduino-avr-core: AVR core with upstream avr-gcc and avrdude')
+ 'arduino-avr-core: AVR core with upstream avr-gcc and avrdude'
+ 'python2: Intel Galileo Board installation')
options=(!strip)
install="arduino.install"
-source=("https://github.com/arduino/Arduino/archive/${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/arduino/Arduino/archive/${pkgver}.tar.gz"
"https://github.com/arduino-libraries/WiFi101-FirmwareUpdater-Plugin/releases/download/v0.8.0/WiFi101-Updater-ArduinoIDE-Plugin-0.8.0.zip"
"https://downloads.arduino.cc/libastylej-2.05.1-3.zip"
"https://downloads.arduino.cc/liblistSerials/liblistSerials-1.1.4.zip"
@@ -57,7 +59,7 @@ build() {
export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH
# Do not include their avr-core + tools and no docs. We build them seperately
- ant clean build -Dlight_bundle=true -Dno_docs=true -Dlocal_sources=true
+ ant clean dist -Dversion=${pkgver} build -Dlight_bundle=true -Dno_docs=true -Dlocal_sources=true
}
package() {
@@ -74,6 +76,9 @@ package() {
# Link arduino-builder, ctags, libastylej, libserialport and docs
# TODO ctags, astyle libserialport do not work yet
+ # https://github.com/arduino/ctags/issues/12
+ # https://github.com/arduino/Arduino/issues/5538
+ # https://github.com/arduino/listSerialPortsC/issues/9
rm "${pkgdir}/usr/share/arduino/arduino-builder"
ln -s /usr/bin/arduino-builder "${pkgdir}/usr/share/arduino/arduino-builder"
# ctags TODO -> patch platform.txt and not the binary ln