summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicoHood2016-08-27 09:20:28 +0200
committerNicoHood2016-08-27 09:20:28 +0200
commit1d6b70f384c0b1a27db308597c131f25ef9b87fb (patch)
treef16084bd410f0510bcf8895512031f84e6a31f8e
parent38855e6a8bbb606a2e4516f3fe127b1350f1996f (diff)
downloadaur-1d6b70f384c0b1a27db308597c131f25ef9b87fb.tar.gz
Added arduino-builder symlink
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5736b648ddcd..c300f2db66cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = arduino-git
pkgdesc = Arduino prototyping platform SDK
- pkgver = 1.6.11.r3.g2e70841
+ pkgver = 1.6.11.r69.ge3177a5
pkgrel = 1
url = https://github.com/arduino/Arduino
install = arduino.install
diff --git a/PKGBUILD b/PKGBUILD
index 9528414e61a1..2258ea71682c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Christopher Loen <christopherloen at gmail dot com>
pkgname=arduino-git
-pkgver=1.6.11.r3.g2e70841
+pkgver=1.6.11.r69.ge3177a5
pkgrel=1
pkgdesc="Arduino prototyping platform SDK"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -39,9 +39,10 @@ package() {
# Copy the whole SDK
cp -a . "${pkgdir}/usr/share/arduino"
- # Create wrapper for java8 + documentation symlink
- install -Dm755 "${srcdir}/arduino.sh" "${pkgdir}/usr/bin/arduino"
- ln -s /usr/share/arduino/reference "${pkgdir}/usr/share/doc/arduino"
+ # Create wrapper for java8 + buider and documentation symlink
+ install -Dm755 "${srcdir}/arduino.sh" "${pkgdir}/usr/bin/arduino"
+ ln -s /usr/share/arduino/arduino-builder "${pkgdir}/usr/bin/arduino-builder"
+ ln -s /usr/share/arduino/reference "${pkgdir}/usr/share/doc/arduino"
# Fix avrdude (see https://github.com/arduino/Arduino/issues/5094)
rm -f "${pkgdir}/usr/share/arduino/hardware/tools/avr/bin/avrdude"{,_bin}