summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Hagström2017-01-06 16:06:05 +0100
committerLars Hagström2017-01-06 16:06:05 +0100
commit36b03a35c4b1a384f3388655e535e292d84e8641 (patch)
treeb88a0d7091a05d6afdea1cea3cbb4dc27634e611
downloadaur-36b03a35c4b1a384f3388655e535e292d84e8641.tar.gz
First version of the package
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
-rw-r--r--adapt_to_arch.patch26
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4c104e6d36d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = arduino-keyboardio-boards-git
+ pkgdesc = Arduino libraries for the Keyboard.io Model01
+ pkgver = r23.0e49d47
+ pkgrel = 1
+ url = https://keyboard.io
+ arch = any
+ license = Unknown
+ depends = arduino
+ source = arduino-keyboardio-boards-git::git+https://github.com/DonOregano/Arduino-Boards.git#branch=remove-flexible-arrays
+ source = adapt_to_arch.patch
+ sha1sums = SKIP
+ sha1sums = e78c9ccd9e4b552a3987bd16526cfb68549c17af
+
+pkgname = arduino-keyboardio-boards-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..305f030abc39
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.pkg.tar.xz
+arduino-keyboardio-boards-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..599bc7daf1c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lars Hagström <lars@foldspace.nu>
+pkgname=arduino-keyboardio-boards-git
+pkgver=r23.0e49d47
+pkgrel=1
+pkgdesc="Arduino libraries for the Keyboard.io Model01"
+arch=('any')
+url="https://keyboard.io"
+license=('Unknown')
+depends=('arduino')
+source=("$pkgname"::"git+https://github.com/DonOregano/Arduino-Boards.git#branch=remove-flexible-arrays"
+ "adapt_to_arch.patch")
+sha1sums=('SKIP'
+ 'e78c9ccd9e4b552a3987bd16526cfb68549c17af')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init
+ patch -Np1 -i "${srcdir}/adapt_to_arch.patch"
+}
+
+package() {
+ install -d $pkgdir/usr/share/arduino/hardware/keyboardio/avr/
+ cd $srcdir
+ cp -R $pkgname/* $pkgdir/usr/share/arduino/hardware/keyboardio/avr/
+}
diff --git a/adapt_to_arch.patch b/adapt_to_arch.patch
new file mode 100644
index 000000000000..c1ea0b1a877e
--- /dev/null
+++ b/adapt_to_arch.patch
@@ -0,0 +1,26 @@
+diff --git a/boards.txt b/boards.txt
+index 1a49c81..8b78040 100644
+--- a/boards.txt
++++ b/boards.txt
+@@ -32,7 +32,7 @@ model01.build.pid=0x2301
+ model01.build.usb_product="Model 01"
+ model01.build.usb_manufacturer="Keyboardio"
+ model01.build.board=AVR_MODEL01
+-model01.build.core=arduino:arduino
++model01.build.core=archlinux-arduino:arduino
+ model01.build.variant=model01
+ model01.build.extra_flags={build.usb_flags}
+
+diff --git a/platform.txt b/platform.txt
+index 91f16f8..d02c738 100644
+--- a/platform.txt
++++ b/platform.txt
+@@ -18,7 +18,7 @@ compiler.warning_flags.more=-Wall
+ compiler.warning_flags.all=-Wall -Wextra
+
+ # Default "compiler.path" is correct, change only if you want to override the initial value
+-compiler.path={runtime.tools.avr-gcc.path}/bin/
++#compiler.path={runtime.tools.avr-gcc.path}/bin/
+ compiler.c.cmd=avr-gcc
+ compiler.c.flags=-c -g -Os {compiler.warning_flags} -std=gnu11 -ffunction-sections -fdata-sections -MMD
+ compiler.c.elf.flags={compiler.warning_flags} -Os -Wl,--gc-sections