summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Whittington2020-11-30 16:39:55 +0100
committerJohn Whittington2020-11-30 16:39:55 +0100
commit976912badf62c753b7c1bfe7ba0fe4943caf6fab (patch)
treeda98da6bfba36459796b457259e6933a584b51b8
parent5e55ff95993208fda4fa30381e74454ee394682c (diff)
downloadaur-976912badf62c753b7c1bfe7ba0fe4943caf6fab.tar.gz
fix makedepends empty error and bring upto date
-rw-r--r--PKGBUILD15
-rw-r--r--platform.patch130
2 files changed, 103 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b33b2637299c..ddbc7b4ddc9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: john <aur {at} jbrengineering {dot} co {dot} uk>
pkgname=arduino-samd-core
-pkgver=1.6.16
+pkgver=1.8.6
pkgrel=3
pkgdesc="Arduino support for SAMD21 series ARM 32 bit microcontrollers (used on Arduino M0 Pro, MKR1000, Arduino Zero etc.)"
arch=('any')
@@ -9,19 +9,18 @@ url="https://github.com/arduino/ArduinoCore-samd"
license=('GPL')
depends=('arm-none-eabi-gcc'
'openocd')
-makedepends=('')
optdepends=('arduino: Arduino IDE: IDE'
'avrdude: M0 uploading support'
'bossa: Zero uploading support')
options=(!strip)
source=("https://downloads.arduino.cc/cores/samd-${pkgver}.tar.bz2"
"https://downloads.arduino.cc/CMSIS-4.5.0.tar.bz2"
- "https://downloads.arduino.cc/CMSIS-Atmel-1.0.0.tar.bz2"
+ "https://downloads.arduino.cc/CMSIS-Atmel-1.2.0.tar.bz2"
"platform.patch")
-sha512sums=('2c300e59d5f48ff196910699530b7c73d3ef4ab4902fd573213cffb7153a480f7c0d91a14f62f3a2034baab1d0c54b7695fce29288ad4c007c55110b741245fb'
+sha512sums=('04275054f628b20ca6851331bbb0c0753f8d7636dba6bb4b396a6c8bf41cf7195128f827947244e0a1b22f48983cb5aac014671a451f7bdc6c69dca6f2d4943e'
'97af9c847c0fec6abfe4769910351f1d85aa19d09b4eea88a3852b3d3f196c7f02b16e0fc9686bcff3d94f8cfae512ab7e550f8fa1abb8db87da7e95c56f5502'
- 'e7286a162f63c0de23db684ebe58b79aade01c47f522b52838cb6adc937daa8a4403de9fdca69c9bae855e27d840843814874b7b18a1b0d360553057f28cd0fc'
- 'ffba11449577f8a7951672725504fd637e5e5a563bfe17ec39cfb6d973c41610a63bb0e8b71d2a6fefe88be169d9dec0dcca281866468738d90cfb712bcc1f68')
+ '2b80184e0487cde3a662f0e04e05ad8d0bf2fb5c64423464017890b1ddc2255acbd9d76be30f195fa4cf460c157ee55c32c354f58337560ba189f448b3e113bc'
+ '141ab6773a42b77408fcc9b358523b99a3ce8e4e91736f1cf6dbeb842df02b83fe1d0f764eea10f97f9ea550eb165ad5940c4e1d7437dc872bae15dd8d06a73d')
prepare()
{
@@ -34,8 +33,8 @@ package() {
# Copy to archlinux arduino folder, within the packages sub directory structured as Arduino IDE
install -dm755 "${pkgdir}/usr/share/arduino/packages/arduino/hardware/samd"
install -dm755 "${pkgdir}/usr/share/arduino/packages/arduino/tools/CMSIS/4.5.0/"
- install -dm755 "${pkgdir}/usr/share/arduino/packages/arduino/tools/CMSIS-Atmel/1.0.0/"
+ install -dm755 "${pkgdir}/usr/share/arduino/packages/arduino/tools/CMSIS-Atmel/1.2.0/"
cp -a "${srcdir}/samd/"* "${pkgdir}/usr/share/arduino/packages/arduino/hardware/samd"
cp -a "${srcdir}/CMSIS/"* "${pkgdir}/usr/share/arduino/packages/arduino/tools/CMSIS/4.5.0/"
- cp -a "${srcdir}/CMSIS-Atmel/"* "${pkgdir}/usr/share/arduino/packages/arduino/tools/CMSIS-Atmel/1.0.0/"
+ cp -a "${srcdir}/CMSIS-Atmel/"* "${pkgdir}/usr/share/arduino/packages/arduino/tools/CMSIS-Atmel/1.2.0/"
}
diff --git a/platform.patch b/platform.patch
index f67dd14fb84b..f3f0b174dba1 100644
--- a/platform.patch
+++ b/platform.patch
@@ -1,46 +1,67 @@
-From 321c218002f989dc7cb693bdabb69b6dd94589ce Mon Sep 17 00:00:00 2001
-From: John Whittington <git@jbrengineering.co.uk>
-Date: Mon, 29 Jan 2018 11:23:45 +0000
-Subject: [PATCH] Patch toolchain and CMSIS path for arch
-
----
- platform.txt | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
diff --git a/platform.txt b/platform.txt
-index 03f054f..a22fa1a 100644
+index 2dbf3ca..2f6e169 100644
--- a/platform.txt
+++ b/platform.txt
-@@ -19,7 +19,7 @@
+@@ -19,8 +19,8 @@
# For more info:
# https://github.com/arduino/Arduino/wiki/Arduino-IDE-1.5---3rd-party-Hardware-specification
-name=Arduino SAMD (32-bits ARM Cortex-M0+) Boards
-+name=Arch Linux Arduino SAMD (32-bits ARM Cortex-M0+) Boards
- version=1.6.16
+-version=1.8.6
++name=Arch Arduino SAMD (32-bits ARM Cortex-M0+) Boards
++version=1.8.9
# Compile variables
-@@ -31,7 +31,7 @@ compiler.warning_flags.default=
- compiler.warning_flags.more=-Wall
- compiler.warning_flags.all=-Wall -Wextra
+ # -----------------
+@@ -28,8 +28,8 @@ version=1.8.6
+ compiler.warning_flags=-w
+ compiler.warning_flags.none=-w
+ compiler.warning_flags.default=
+-compiler.warning_flags.more=-Wall -Wno-expansion-to-defined
+-compiler.warning_flags.all=-Wall -Wextra -Wno-expansion-to-defined
++compiler.warning_flags.more=-Wall
++compiler.warning_flags.all=-Wall -Wextra
--compiler.path={runtime.tools.arm-none-eabi-gcc.path}/bin/
+ # EXPERIMENTAL feature: optimization flags
+ # - this is alpha and may be subject to change without notice
+@@ -37,7 +37,7 @@ compiler.optimization_flags=-Os
+ compiler.optimization_flags.release=-Os
+ compiler.optimization_flags.debug=-Og -g3
+
+-compiler.path={runtime.tools.arm-none-eabi-gcc-7-2017q4.path}/bin/
+compiler.path=/usr/bin/
compiler.c.cmd=arm-none-eabi-gcc
- compiler.c.flags=-mcpu={build.mcu} -mthumb -c -g -Os {compiler.warning_flags} -std=gnu11 -ffunction-sections -fdata-sections -nostdlib --param max-inline-insns-single=500 -MMD
- compiler.c.elf.cmd=arm-none-eabi-gcc
-@@ -64,8 +64,8 @@ compiler.S.extra_flags=
+ compiler.c.flags=-mcpu={build.mcu} -mthumb -c -g {compiler.optimization_flags} {compiler.warning_flags} -std=gnu11 -ffunction-sections -fdata-sections -nostdlib --param max-inline-insns-single=500 -MMD
+ compiler.c.elf.cmd=arm-none-eabi-g++
+@@ -70,8 +70,8 @@ compiler.S.extra_flags=
compiler.ar.extra_flags=
compiler.elf2hex.extra_flags=
--compiler.arm.cmsis.c.flags="-I{runtime.tools.CMSIS-4.5.0.path}/CMSIS/Include/" "-I{runtime.tools.CMSIS-Atmel-1.1.0.path}/CMSIS/Device/ATMEL/"
+-compiler.arm.cmsis.c.flags="-I{runtime.tools.CMSIS-4.5.0.path}/CMSIS/Include/" "-I{runtime.tools.CMSIS-Atmel-1.2.0.path}/CMSIS/Device/ATMEL/"
-compiler.arm.cmsis.ldflags="-L{runtime.tools.CMSIS-4.5.0.path}/CMSIS/Lib/GCC/" -larm_cortexM0l_math
-+compiler.arm.cmsis.c.flags="-I/usr/share/arduino/packages/arduino/tools/CMSIS/4.5.0/CMSIS/Include/" "-I/usr/share/arduino/packages/arduino/tools/CMSIS-Atmel/1.0.0/CMSIS/Device/ATMEL/"
++compiler.arm.cmsis.c.flags="-I/usr/share/arduino/packages/arduino/tools/CMSIS/4.5.0/CMSIS/Include/" "-I/usr/share/arduino/packages/arduino/tools/CMSIS-Atmel/1.2.0/CMSIS/Device/ATMEL/"
+compiler.arm.cmsis.ldflags="-L/usr/share/arduino/packages/arduino/tools/CMSIS/4.5.0/CMSIS/Lib/GCC/" -larm_cortexM0l_math
- # USB Flags
- # ---------
-@@ -117,7 +117,7 @@ recipe.size.regex=\.text\s+([0-9]+).*
+ compiler.libraries.ldflags=
+
+@@ -87,13 +87,13 @@ build.usb_manufacturer="Unknown"
+ # ----------------
+
+ ## Compile c files
+-recipe.c.o.pattern="{compiler.path}{compiler.c.cmd}" {compiler.c.flags} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.c.extra_flags} {build.extra_flags} {compiler.arm.cmsis.c.flags} {includes} "{source_file}" -o "{object_file}"
++recipe.c.o.pattern="{compiler.path}{compiler.c.cmd}" {compiler.c.flags} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.c.extra_flags} {build.extra_flags} {compiler.arm.cmsis.c.flags} "-I{build.core.path}/api/deprecated" {includes} "{source_file}" -o "{object_file}"
+
+ ## Compile c++ files
+-recipe.cpp.o.pattern="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {compiler.arm.cmsis.c.flags} {includes} "{source_file}" -o "{object_file}"
++recipe.cpp.o.pattern="{compiler.path}{compiler.cpp.cmd}" {compiler.cpp.flags} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.cpp.extra_flags} {build.extra_flags} {compiler.arm.cmsis.c.flags} "-I{build.core.path}/api/deprecated" {includes} "{source_file}" -o "{object_file}"
+
+ ## Compile S files
+-recipe.S.o.pattern="{compiler.path}{compiler.S.cmd}" {compiler.S.flags} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.S.extra_flags} {build.extra_flags} {compiler.arm.cmsis.c.flags} {includes} "{source_file}" -o "{object_file}"
++recipe.S.o.pattern="{compiler.path}{compiler.S.cmd}" {compiler.S.flags} -DF_CPU={build.f_cpu} -DARDUINO={runtime.ide.version} -DARDUINO_{build.board} -DARDUINO_ARCH_{build.arch} {compiler.S.extra_flags} {build.extra_flags} {compiler.arm.cmsis.c.flags} "-I{build.core.path}/api/deprecated" {includes} "{source_file}" -o "{object_file}"
+
+ ## Create archives
+ # archive_file_path is needed for backwards compatibility with IDE 1.6.5 or older, IDE 1.6.6 or newer overrides this value
+@@ -126,7 +126,7 @@ recipe.size.regex.data=^(?:\.data|\.bss)\s+([0-9]+).*
#
# AVRDUDE
#
@@ -49,33 +70,74 @@ index 03f054f..a22fa1a 100644
tools.avrdude.cmd={path}/bin/avrdude
tools.avrdude.config.path={path}/etc/avrdude.conf
-@@ -131,7 +131,7 @@ tools.avrdude_remote.upload.pattern="openocd --version 2>&1 | grep 2016 && if op
+@@ -143,7 +143,7 @@ tools.avrdude.upload.network_pattern="{network_cmd}" -address {serial.port} -por
#
# BOSSA
#
--tools.bossac.path={runtime.tools.bossac-1.7.0.path}
+-tools.bossac.path={runtime.tools.bossac-1.7.0-arduino3.path}
+tools.bossac.path=/usr/bin/
tools.bossac.cmd=bossac
tools.bossac.cmd.windows=bossac.exe
-@@ -148,7 +148,7 @@ tools.bossac.upload.network_pattern="{network_cmd}" -address {serial.port} -port
+@@ -153,13 +153,14 @@ tools.bossac.upload.pattern="{path}/{cmd}" {upload.verbose} --port={serial.port.
+
+ tools.bossac_remote.upload.pattern=/usr/bin/run-bossac {upload.verbose} --port=ttyATH0 -U {upload.native_usb} -e -w -v /tmp/sketch.bin -R
+
+-tools.bossac.network_cmd={runtime.tools.arduinoOTA.path}/bin/arduinoOTA
+-tools.bossac.upload.network_pattern="{network_cmd}" -address {serial.port} -port 65280 -username arduino -password "{network.password}" -sketch "{build.path}/{build.project_name}.bin" -upload /sketch -b
++arduinoota.extraflags=
++tools.bossac.network_cmd={runtime.tools.arduinoOTA-1.3.0.path}/bin/arduinoOTA
++tools.bossac.upload.network_pattern="{network_cmd}" -address {serial.port} -port 65280 -username arduino -password "{network.password}" -sketch "{build.path}/{build.project_name}.bin" -upload /sketch -b {arduinoota.extraflags}
+
+ #
+ # BOSSA (ignore binary size)
+ #
+-tools.bossacI.path={runtime.tools.bossac-1.7.0-arduino3.path}
++tools.bossacI.path=/usr/bin/
+ tools.bossacI.cmd=bossac
+ tools.bossacI.cmd.windows=bossac.exe
+
+@@ -177,7 +178,7 @@ tools.bossacI.upload.network_pattern="{network_cmd}" -address {serial.port} -por
# OpenOCD sketch upload
#
--tools.openocd.path={runtime.tools.openocd-0.9.0-arduino6-static.path}
+-tools.openocd.path={runtime.tools.openocd-0.10.0-arduino7.path}
+tools.openocd.path=/usr/
tools.openocd.cmd=bin/openocd
tools.openocd.cmd.windows=bin/openocd.exe
-@@ -177,7 +177,7 @@ tools.openocd.bootloader.pattern="{path}/{cmd}" {bootloader.verbose} -s "{path}/
+@@ -188,10 +189,9 @@ tools.openocd.upload.pattern="{path}/{cmd}" {upload.verbose} -s "{path}/share/op
+ tools.openocd.network_cmd={runtime.tools.arduinoOTA.path}/bin/arduinoOTA
+ tools.openocd.upload.network_pattern={network_cmd} -address {serial.port} -port 65280 -username arduino -password "{network.password}" -sketch "{build.path}/{build.project_name}.bin" -upload /sketch -b
+
+-# Program flashes the binary at 0x0000, so use the linker script without_bootloader
+ tools.openocd.program.params.verbose=-d2
+ tools.openocd.program.params.quiet=-d0
+-tools.openocd.program.pattern="{path}/{cmd}" {program.verbose} -s "{path}/share/openocd/scripts/" -f "{runtime.platform.path}/variants/{build.variant}/{build.openocdscript}" -c "telnet_port disabled; program {{build.path}/{build.project_name}.elf} verify reset; shutdown"
++tools.openocd.program.pattern="{path}/{cmd}" {program.verbose} -s "{path}/share/openocd/scripts/" -f "{runtime.platform.path}/variants/{build.variant}/{build.openocdscript}" -c "telnet_port disabled; program {{build.path}/{build.project_name}.hex} verify reset; shutdown"
+
+ tools.openocd.erase.params.verbose=-d3
+ tools.openocd.erase.params.quiet=-d0
+@@ -206,7 +206,7 @@ tools.openocd.bootloader.pattern="{path}/{cmd}" {bootloader.verbose} -s "{path}/
# FIXME: this programmer is a workaround for default options being overwritten by uploadUsingPreferences
#
--tools.openocd-withbootsize.path={runtime.tools.openocd-0.9.0-arduino6-static.path}
+-tools.openocd-withbootsize.path={runtime.tools.openocd-0.10.0-arduino7.path}
+tools.openocd-withbootsize.path=/usr/
tools.openocd-withbootsize.cmd=bin/openocd
tools.openocd-withbootsize.cmd.windows=bin/openocd.exe
---
-2.16.1
-
+@@ -232,8 +232,8 @@ tools.openocd-withbootsize.bootloader.pattern="{path}/{cmd}" {bootloader.verbose
+ #
+ # EXPERIMENTAL feature: debug.pattern
+ # - this is alpha and may be subject to change without notice
+-
+-tools.gdb.path={runtime.tools.arm-none-eabi-gcc-7-2017q4.path}/bin/
+-tools.gdb.cmd=arm-none-eabi-gdb
+-tools.gdb.cmd.windows=arm-none-eabi-gdb.exe
+-tools.gdb.debug.pattern="{path}/{cmd}" --interpreter=mi2 -ex "set pagination off" -ex 'target extended-remote | {tools.openocd.path}/{tools.openocd.cmd} -s "{tools.openocd.path}/share/openocd/scripts/" --file "{runtime.platform.path}/variants/{build.variant}/{build.openocdscript}" -c "gdb_port pipe" -c "telnet_port 0"' {build.path}/{build.project_name}.elf
++tools.gdb-openocd.path=/usr/bin/
++tools.gdb-openocd.cmd=arm-none-eabi-gdb
++tools.gdb-openocd.cmd.windows=arm-none-eabi-gdb.exe
++tools.gdb-openocd.interpreter=console
++tools.gdb-openocd.debug.pattern="{path}/{cmd}" --interpreter={interpreter} -ex "set remotetimeout 5" -ex "set pagination off" -ex 'target extended-remote | "{tools.openocd.path}/{tools.openocd.cmd}" -s "{tools.openocd.path}/share/openocd/scripts/" --file "{runtime.platform.path}/variants/{build.variant}/{build.openocdscript}" -c "gdb_port pipe" -c "telnet_port 0"' "{build.path}/{build.project_name}.elf"