summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-02-25 17:12:01 -0500
committeracxz2022-02-25 17:12:01 -0500
commit30b03e1a139006fcd93e40afb00a2e49aa810cb2 (patch)
tree4de56120190883ae856ad1aa2d506b429b3396a1
parent23cb9390f13e64e8a64f74f4ece2be2333cbde53 (diff)
downloadaur-30b03e1a139006fcd93e40afb00a2e49aa810cb2.tar.gz
upgpkg: ardupilot-gazebo-sitl-git
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 6 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f7834d41d3a..d0f0af186406 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ardupilot-gazebo-sitl-git
pkgdesc = Gazebo plugin for Ardupilot's SITL.
- pkgver = r34.e72ecf5
- pkgrel = 3
+ pkgver = r38.350dcbb
+ pkgrel = 1
url = https://ardupilot.org/dev/docs/using-gazebo-simulator-with-sitl.html
arch = x86_64
license = GPLv3
@@ -10,10 +10,6 @@ pkgbase = ardupilot-gazebo-sitl-git
optdepends = ardupilot-sitl
provides = ardupilot-gazebo-sitl
source = ardupilot-gazebo-stil::git+https://github.com/khancyr/ardupilot_gazebo.git
- source = xacro.patch::https://github.com/khancyr/ardupilot_gazebo/pull/42.patch
- source = c++-std.patch::https://github.com/khancyr/ardupilot_gazebo/pull/50.patch
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = SKIP
pkgname = ardupilot-gazebo-sitl-git
diff --git a/PKGBUILD b/PKGBUILD
index 6a401a3a7015..b3ae25fb3efd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=ardupilot-gazebo-sitl-git
-pkgver=r34.e72ecf5
-pkgrel=3
+pkgver=r38.350dcbb
+pkgrel=1
pkgdesc="Gazebo plugin for Ardupilot's SITL."
arch=('x86_64')
url='https://ardupilot.org/dev/docs/using-gazebo-simulator-with-sitl.html'
@@ -11,24 +11,14 @@ optdepends=('ardupilot-sitl')
makedepends=('cmake')
provides=('ardupilot-gazebo-sitl')
_pkgname=ardupilot-gazebo-stil
-source=("${_pkgname}::git+https://github.com/khancyr/ardupilot_gazebo.git"
- "xacro.patch"::"https://github.com/khancyr/ardupilot_gazebo/pull/42.patch"
- "c++-std.patch"::"https://github.com/khancyr/ardupilot_gazebo/pull/50.patch")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=("${_pkgname}::git+https://github.com/khancyr/ardupilot_gazebo.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$_pkgname"
- patch --forward --strip=1 --input="${srcdir}/xacro.patch"
- patch --forward --strip=1 --input="${srcdir}/c++-std.patch"
-}
-
build() {
mkdir -p ${srcdir}/${_pkgname}/build
cd ${srcdir}/${_pkgname}/build