summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatěj Týč2015-08-23 23:46:47 +0200
committerMatěj Týč2015-08-23 23:46:47 +0200
commit0e8b21b9e9aab30a8e1cc52b612cfd27625141ac (patch)
treefffb3d932b853c9df70080b704d0ec239a43871c
downloadaur-0e8b21b9e9aab30a8e1cc52b612cfd27625141ac.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD48
-rw-r--r--argbash-1.0.0.tar.gzbin0 -> 25639 bytes
4 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1905c4e2d4ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = argbash
+ pkgdesc = Bash argument parsing code generator
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/matejak/argbash
+ arch = any
+ license = BSD
+ makedepends = make
+ depends = autoconf
+ source = argbash-1.0.0.tar.gz
+ source = LICENSE
+ md5sums = cbd075a8e13f7e7ee32e33f8cc191f41
+ md5sums = 830d8b1dc53dad7f53d6112c924c91ec
+
+pkgname = argbash
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..102ff588b43f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,28 @@
+Copyright (c) 2015, Matěj Týč
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+* Neither the name of argbash nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63fd7768bf50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <matej.tyc@gmail.com>
+pkgname=argbash
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Bash argument parsing code generator"
+arch=(any)
+url="https://github.com/matejak/argbash"
+license=('BSD')
+groups=()
+depends=('autoconf')
+makedepends=('make')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz" LICENSE)
+noextract=()
+md5sums=('cbd075a8e13f7e7ee32e33f8cc191f41' '830d8b1dc53dad7f53d6112c924c91ec')
+validpgpkeys=()
+
+build() {
+ true
+}
+
+check() {
+ cd "$pkgname-$pkgver/resources"
+ make -k check
+}
+
+package() {
+ LICENSES="$pkgdir/usr/share/licenses/$pkgname"
+ mkdir -p "$LICENSES"
+ cp LICENSE "$LICENSES"
+
+ cd "$pkgname-$pkgver/resources"
+ make ROOT="$pkgdir" PREFIX="/usr" install
+}
diff --git a/argbash-1.0.0.tar.gz b/argbash-1.0.0.tar.gz
new file mode 100644
index 000000000000..e00cbd49cccd
--- /dev/null
+++ b/argbash-1.0.0.tar.gz
Binary files differ