summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Stelle2017-09-14 12:00:22 -0600
committerGeorge Stelle2017-09-14 12:00:22 -0600
commit3e098ab549a6a78863420a2970c5993dbcb4a1ae (patch)
tree45e0f70248f8df57245df9ced2a82d4ba5e0b073
downloadaur-3e098ab549a6a78863420a2970c5993dbcb4a1ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..929fdb9d4f68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Thu Sep 14 17:57:00 UTC 2017
+pkgbase = argobots-git
+ pkgdesc = Lightweight, low-level threading and tasking framework
+ pkgver = v1.0a1.r46.g8394f8a
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ makedepends = git automake autoconf gcc libtool
+ source = argobots-git::git+https://github.com/pmodels/argobots.git
+ md5sums = SKIP
+
+pkgname = argobots-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cd60f15faf3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: George Stelle <stelleg@gmail.com>
+pkgname=argobots-git
+pkgver=v1.0a1.r46.g8394f8a
+pkgrel=1
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+pkgdesc="Lightweight, low-level threading and tasking framework"
+arch=('x86_64')
+url=""
+license=('GPL')
+source=("$pkgname"::"git+https://github.com/pmodels/argobots.git")
+noextract=()
+md5sums=('SKIP')
+makedepends=('git automake autoconf gcc libtool')
+
+build() {
+ cd "$pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}