aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCh4s3r2023-01-30 20:24:47 +0100
committerCh4s3r2023-01-30 20:55:41 +0100
commitb2af808fd63f227b4a5d8fc765b5635b8c27a7b0 (patch)
tree75056af3693f8877b9747b09f6106afebc6704f1
parent0ca8438633e96365b6491607ecf01a25b7c2ca67 (diff)
downloadaur-b2af808fd63f227b4a5d8fc765b5635b8c27a7b0.tar.gz
chore: add Dockerfile for building
-rw-r--r--Dockerfile4
-rwxr-xr-x[-rw-r--r--]PKGBUILD28
-rw-r--r--README.md10
3 files changed, 36 insertions, 6 deletions
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..0dd33dea30f5
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,4 @@
+FROM samip537/archlinux:yay
+WORKDIR /app
+COPY PKGBUILD ./
+CMD makepkg -f
diff --git a/PKGBUILD b/PKGBUILD
index a4d1644dee75..311093223988 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer: Ch4s3r <lamprecht.patrick1@gmail.com>
pkgname=argocd-autopilot-bin
-pkgver=v0.0.0
-pkgrel=2
+pkgver=v0.4.11
+pkgrel=1
pkgdesc="Argo-CD Autopilot is a tool which offers an opinionated way of installing Argo-CD and managing GitOps repositories."
-arch=(x86_64)
+arch=(x86_64 aarch64)
url="https://github.com/argoproj-labs/argocd-autopilot"
-source=("https://github.com/Ch4s3r/argocd-autopilot-bin.git")
license=('Apache')
provides=(argocd-autopilot)
@@ -14,6 +13,23 @@ pkgver() {
}
package() {
- curl -L --output - https://github.com/argoproj-labs/argocd-autopilot/releases/download/$pkgver/argocd-autopilot-linux-amd64.tar.gz | tar zx
- install -Dm755 argocd-autopilot-* "$pkgdir/usr/bin/argocd-autopilot"
+ if [[ $CARCH == aarch64 ]]; then
+ ARCH=arm64
+ else
+ ARCH=amd64
+ fi
+
+ curl -L --output - https://github.com/argoproj-labs/argocd-autopilot/releases/download/$pkgver/argocd-autopilot-linux-$ARCH.tar.gz | tar zx
+
+ mv argocd-autopilot-* argocd-autopilot
+ install -Dm755 argocd-autopilot "$pkgdir/usr/bin/argocd-autopilot"
+
+ ./argocd-autopilot completion bash > completion
+ install -Dm755 completion "$pkgdir/usr/share/bash-completion/completions/argocd-autopilot"
+
+ ./argocd-autopilot completion bash > completion
+ install -Dm755 completion "$pkgdir/usr/share/fish/vendor_completions.d/argocd-autopilot.fish"
+
+ ./argocd-autopilot completion bash > completion
+ install -Dm755 completion "$pkgdir/usr/share/zsh/site-functions/_argocd-autopilot"
}
diff --git a/README.md b/README.md
index d588f76120a4..62ca5f5638bc 100644
--- a/README.md
+++ b/README.md
@@ -10,4 +10,14 @@ git remote add aur ssh://aur@aur.archlinux.org/argocd-autopilot-bin.git
```shell
git push aur main:master
+```
+
+## Building locally in container
+
+```shell
+docker build -t makepkg .
+```
+
+```shell
+docker run --rm -it makepkg
``` \ No newline at end of file