summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfossdd2021-06-12 12:38:41 +0000
committerfossdd2021-06-12 12:38:41 +0000
commit94a2e3081005cf9609e1b59fdcdf0470fabc2baa (patch)
tree6f24f17cfa4a857d4558728829683a03bac652f2
parentedff30c72278d1ccdf013294a2f6d75fc07f94b7 (diff)
downloadaur-94a2e3081005cf9609e1b59fdcdf0470fabc2baa.tar.gz
add dependencies fix by Nullrequest
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
-rwxr-xr-xargos-translate-git.install3
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0dd5c163333..b2f05dd99b7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,17 +3,22 @@ pkgbase = argos-translate-git
pkgver = r231.8c4e64e
pkgrel = 1
url = https://github.com/argosopentech/argos-translate
- install = argos-translate-git.install
arch = any
license = MIT
makedepends = python-setuptools
makedepends = git
depends = python
depends = python-pip
+ depends = python-requests
+ depends = python-pyqt5
+ depends = python-stanza
+ depends = python-sentencepiece-git
+ depends = ctranslate2-git
+ optdepends = python-sphinx
+ optdepends = python-sphinx_rtd_theme
provides = argos-translate
provides = argos-translate-cli
source = git+https://github.com/argosopentech/argos-translate.git
sha256sums = SKIP
pkgname = argos-translate-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6677b145c1e0..f7745c4caca8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: fossdd <fossdd@tutanota.com>
+# Contributor: Advaith Madhukar <advaith.madhukar@gmail.com>
pkgname=argos-translate-git
_pkgname=argos-translate
pkgver=r231.8c4e64e
@@ -8,9 +9,9 @@ arch=(any)
url="https://github.com/argosopentech/argos-translate"
provides=('argos-translate' 'argos-translate-cli')
license=(MIT)
-depends=('python' 'python-pip')
+depends=('python' 'python-pip' 'python-requests' 'python-pyqt5' 'python-stanza' 'python-sentencepiece-git' 'ctranslate2-git')
+optdepends=('python-sphinx' 'python-sphinx_rtd_theme')
makedepends=('python-setuptools' 'git')
-install="argos-translate-git.install"
source=('git+https://github.com/argosopentech/argos-translate.git')
sha256sums=('SKIP')
@@ -31,4 +32,3 @@ package() {
cd ${_pkgname}
python setup.py install --root="$pkgdir/" --optimize=1
}
-
diff --git a/argos-translate-git.install b/argos-translate-git.install
deleted file mode 100755
index 41043b68c355..000000000000
--- a/argos-translate-git.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install() {
- pip install ctranslate2 sentencepiece stanza
-}