summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKen2017-01-13 12:33:25 +0100
committerKen2017-01-13 12:33:25 +0100
commita14e80de8a94a022d26eecef7ff57d1b7f18a533 (patch)
treee4bff7f57f2e37d2304340f2b51529f455ac1403
downloadaur-a14e80de8a94a022d26eecef7ff57d1b7f18a533.tar.gz
adding of epuck library for argos3 simulator
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c43ed62f6ba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = argos3-epuck-git
+ pkgdesc = ARGoS3 simulator library for epuck robot
+ pkgver = r12.fe0e358
+ pkgrel = 1
+ url = https://github.com/lgarattoni/argos3-epuck
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = gcc>=4.4
+ makedepends = git
+ makedepends = cmake>=2.8
+ depends = argos3-git
+ source = git://github.com/lgarattoni/argos3-epuck.git
+ md5sums = SKIP
+
+pkgname = argos3-epuck-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f890dda8593
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Ken Hasselmann <arch AT kenh DOT fr>
+
+pkgname=argos3-epuck-git
+_gitname=argos3-epuck
+pkgver=r12.fe0e358
+pkgrel=1
+
+pkgdesc="ARGoS3 simulator library for epuck robot"
+arch=('i686' 'x86_64')
+url="https://github.com/lgarattoni/argos3-epuck"
+license=('MIT')
+
+depends=('argos3-git')
+makedepends=('gcc>=4.4' 'git' 'cmake>=2.8')
+
+source=('git://github.com/lgarattoni/argos3-epuck.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ # Use the revision number
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ mkdir build_simulator
+ cd build_simulator
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../src
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ cd build_simulator
+ make DESTDIR="$pkgdir/" install
+}
+