summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlrossin2023-01-09 15:19:36 -0500
committerlrossin2023-01-09 15:19:36 -0500
commitf7ef5bae0dde3e00050c40f10f5c6941aad7d7aa (patch)
treee76ad0c8edd7cae6150c68c5ca8dad47e2c9c987
downloadaur-f7ef5bae0dde3e00050c40f10f5c6941aad7d7aa.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
-rw-r--r--argouml.desktop7
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0db715174cef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = argouml-bin
+ pkgdesc = UML 1.4 modeller
+ pkgver = 0.35.1
+ pkgrel = 1
+ url = https://argouml-tigris-org.github.io/
+ arch = any
+ license = EPL
+ depends = java-runtime
+ source = argouml-bin-0.35.1.tar.gz::https://github.com/argouml-tigris-org/argouml/releases/download/VERSION_0_35_1/ArgoUML-0.35.1.tar.gz
+ source = argouml.desktop
+ sha256sums = 5e5230eb1bd29c545ae6fd56c0bdfbee86b1e6c2c538d6df22728fa3e3ab1639
+ sha256sums = b3d19c56d8c81bb75d4a9b3b994acd2db5ccad144db7d6b0c0cd5487b54a9157
+
+pkgname = argouml-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ea42d2df957e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.tar.gz
+*.tar.xz
+*.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a2a900246d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lynden Rossin <lynden.rossin at gmail dot com>
+# Contributor: Manish Munikar <munikarmanish at gmail dot com>
+
+pkgname=argouml-bin
+_pkgname=argouml
+pkgver=0.35.1
+pkgrel=1
+pkgdesc="UML 1.4 modeller"
+arch=('any')
+url="https://argouml-tigris-org.github.io/"
+license=('EPL')
+depends=('java-runtime')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/argouml-tigris-org/argouml/releases/download/VERSION_0_35_1/ArgoUML-0.35.1.tar.gz"
+ "${_pkgname}.desktop");
+noextract=()
+sha256sums=('5e5230eb1bd29c545ae6fd56c0bdfbee86b1e6c2c538d6df22728fa3e3ab1639'
+ 'b3d19c56d8c81bb75d4a9b3b994acd2db5ccad144db7d6b0c0cd5487b54a9157')
+validpgpkeys=()
+
+package() {
+ # Creating directories
+ mkdir -p ${pkgdir}/opt/${_pkgname}
+ mkdir -p ${pkgdir}/usr/bin/
+ mkdir -p ${pkgdir}/usr/share/applications/
+
+ msg2 "Copying source files..."
+ cp -pR ${srcdir}/${_pkgname}-${pkgver}/* ${pkgdir}/opt/${_pkgname}/
+
+ msg2 "Creating executable file..."
+ ln -s "/opt/argouml/argouml.sh" ${pkgdir}/usr/bin/${_pkgname}
+
+ msg2 "Creating desktop entry..."
+ cp -p ${srcdir}/${_pkgname}.desktop ${pkgdir}/usr/share/applications/${_pkgname}.desktop
+}
diff --git a/argouml.desktop b/argouml.desktop
new file mode 100644
index 000000000000..0669961d8153
--- /dev/null
+++ b/argouml.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=ArgoUML
+Type=Application
+Exec=argouml
+Comment=UML 1.4 modeller
+Categories=Education;Engineering;Development;Programming;Science;Graphics;
+Icon=/opt/argouml/icon/ArgoIcon256x256.png