summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora-wing2019-03-13 01:04:58 +0800
committera-wing2019-03-13 01:04:58 +0800
commite07cfcc6667a96141e31e6a4066a6029080cf56d (patch)
treedf3e21c9989a442717ef2889b4f7428581dcb421
downloadaur-e07cfcc6667a96141e31e6a4066a6029080cf56d.tar.gz
Init argus
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD22
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..175ec7a580d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = argus
+ pkgdesc = auxiliary reliable guardian undertaking system
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://github.com/JRT-FOREVER/argus
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-bottle
+ source = git+https://github.com/JRT-FOREVER/argus
+ sha256sums = SKIP
+
+pkgname = argus
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..283e21233ab3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+### https://raw.github.com/github/gitignore/8edb8a95c4c4b3dce71a378aaaf89275510b9cef/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82fe96895cdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Metal A-wing <1 at 233 dot email>
+
+pkgname=argus
+pkgver=3.0
+pkgrel=1
+pkgdesc="auxiliary reliable guardian undertaking system"
+arch=('any')
+url="https://github.com/JRT-FOREVER/argus"
+license=('GPL3')
+depends=('python' 'python-bottle')
+
+#source=("$pkgname-$pkgver.tar.gz::${url}/archive/v$pkgver.tar.gz")
+#md5sums=('SKIP')
+
+source=("git+${url}")
+sha256sums=('SKIP')
+
+package() {
+ cd ${pkgname}
+ PREFIX=$pkgdir make install
+}
+