summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPandada82015-06-14 02:05:06 +0800
committerPandada82015-06-14 02:05:06 +0800
commitd99d84a08a876802dbb375caf1c61dc6ad9a8b2b (patch)
tree157e22e23b003f57c0f3875b665e27d9378f9345
downloadaur-d99d84a08a876802dbb375caf1c61dc6ad9a8b2b.tar.gz
init with 1.19.0
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
-rw-r--r--aria2-1.16.patch93
3 files changed, 166 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21c563dc6cee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = aria2-fast
+ pkgdesc = Aria2 Download utility with little patch to maximize aria2 download connections
+ pkgver = 1.19.0
+ pkgrel = 1
+ url = http://aria2.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ checkdepends = cppunit
+ depends = gnutls
+ depends = libxml2
+ depends = sqlite
+ depends = c-ares
+ depends = ca-certificates
+ provides = aria2
+ conflicts = aria2
+ source = http://downloads.sourceforge.net/aria2/aria2-1.19.0.tar.bz2
+ source = aria2-1.16.patch
+ md5sums = ad6eb57511a05ce823e194eb71a7e9fa
+ md5sums = b4e0837bd7c255b645c9a8bbdd550e3f
+
+pkgname = aria2-fast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc7577e85856
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Pandada8 < pandada8@gmail.com >
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Alexander Fehr <pizzapunk gmail com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=aria2-fast
+pkgver=1.19.0
+pkgrel=1
+pkgdesc='Aria2 Download utility with little patch to maximize aria2 download connections'
+arch=('i686' 'x86_64')
+url='http://aria2.sourceforge.net/'
+license=('GPL')
+depends=('gnutls' 'libxml2' 'sqlite' 'c-ares' 'ca-certificates')
+checkdepends=('cppunit')
+provides=('aria2')
+conflicts=('aria2')
+source=("http://downloads.sourceforge.net/aria2/aria2-${pkgver}.tar.bz2" "aria2-1.16.patch")
+
+build() {
+ cd aria2-${pkgver}
+
+ patch -Np1 < ../aria2-1.16.patch
+
+ ./configure \
+ --prefix=/usr \
+ --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
+
+ make
+}
+
+check() {
+ cd aria2-${pkgver}
+
+ make check
+}
+
+package() {
+ cd aria2-${pkgver}
+
+ make DESTDIR=${pkgdir} install
+
+ # add bash completion (aria2 automatically installs to a temporary target directory)
+ install -d ${pkgdir}/usr/share/bash-completion/completions
+ install -m644 ${pkgdir}/usr/share/doc/aria2/bash_completion/aria2c \
+ ${pkgdir}/usr/share/bash-completion/completions
+ rm -rf ${pkgdir}/usr/share/doc/aria2/bash_completion
+}
+md5sums=('ad6eb57511a05ce823e194eb71a7e9fa'
+ 'b4e0837bd7c255b645c9a8bbdd550e3f')
diff --git a/aria2-1.16.patch b/aria2-1.16.patch
new file mode 100644
index 000000000000..2ff6ae2c6966
--- /dev/null
+++ b/aria2-1.16.patch
@@ -0,0 +1,93 @@
+diff -Npur ../aria2-1.16.0.ori/src/HttpSkipResponseCommand.cc ./src/HttpSkipResponseCommand.cc
+--- ../aria2-1.16.0.ori/src/HttpSkipResponseCommand.cc 2012-12-16 10:59:30.274471789 +0700
++++ ./src/HttpSkipResponseCommand.cc 2012-12-16 11:06:09.824474859 +0700
+@@ -11,7 +11,7 @@
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See th e
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+@@ -209,7 +209,7 @@ bool HttpSkipResponseCommand::processRes
+ } else if(statusCode == 404) {
+ throw DL_ABORT_EX2(MSG_RESOURCE_NOT_FOUND,
+ error_code::RESOURCE_NOT_FOUND);
+- } else if(statusCode == 503) {
++ } else if(statusCode == 503 or statusCode == 502 or statusCode == 403) {
+ // Only retry if pretry-wait > 0. Hammering 'busy' server is not
+ // a good idea.
+ if(getOption()->getAsInt(PREF_RETRY_WAIT) > 0) {
+diff -Npur ../aria2-1.16.0.ori/src/OptionHandlerFactory.cc ./src/OptionHandlerFactory.cc
+--- ../aria2-1.16.0.ori/src/OptionHandlerFactory.cc 2012-12-16 10:59:30.284471787 +0700
++++ ./src/OptionHandlerFactory.cc 2012-12-16 11:04:24.561140718 +0700
+@@ -480,8 +480,8 @@ std::vector<OptionHandler*> OptionHandle
+ OptionHandler* op(new NumberOptionHandler
+ (PREF_MAX_CONNECTION_PER_SERVER,
+ TEXT_MAX_CONNECTION_PER_SERVER,
+- "1",
+- 1, 16,
++ "128",
++ 1, -1,
+ 'x'));
+ op->addTag(TAG_BASIC);
+ op->addTag(TAG_FTP);
+@@ -546,8 +546,8 @@ std::vector<OptionHandler*> OptionHandle
+ OptionHandler* op(new UnitNumberOptionHandler
+ (PREF_MIN_SPLIT_SIZE,
+ TEXT_MIN_SPLIT_SIZE,
+- "20M",
+- 1024*1024, 1024*1024*1024,
++ "16K",
++ 1024, 1024*1024*1024,
+ 'k'));
+ op->addTag(TAG_BASIC);
+ op->addTag(TAG_FTP);
+@@ -859,7 +859,7 @@ std::vector<OptionHandler*> OptionHandle
+ OptionHandler* op(new NumberOptionHandler
+ (PREF_CONNECT_TIMEOUT,
+ TEXT_CONNECT_TIMEOUT,
+- "60",
++ "30",
+ 1, 600));
+ op->addTag(TAG_FTP);
+ op->addTag(TAG_HTTP);
+@@ -910,7 +910,7 @@ std::vector<OptionHandler*> OptionHandle
+ OptionHandler* op(new NumberOptionHandler
+ (PREF_MAX_TRIES,
+ TEXT_MAX_TRIES,
+- "5",
++ "0",
+ 0, -1,
+ 'm'));
+ op->addTag(TAG_FTP);
+@@ -954,8 +954,8 @@ std::vector<OptionHandler*> OptionHandle
+ OptionHandler* op(new UnitNumberOptionHandler
+ (PREF_PIECE_LENGTH,
+ TEXT_PIECE_LENGTH,
+- "1M",
+- 1024*1024,
++ "16K",
++ 1024,
+ 1024*1024*1024));
+ op->addTag(TAG_ADVANCED);
+ op->addTag(TAG_FTP);
+@@ -982,7 +982,7 @@ std::vector<OptionHandler*> OptionHandle
+ OptionHandler* op(new NumberOptionHandler
+ (PREF_RETRY_WAIT,
+ TEXT_RETRY_WAIT,
+- "0",
++ "4",
+ 0, 600));
+ op->addTag(TAG_FTP);
+ op->addTag(TAG_HTTP);
+@@ -1040,7 +1040,7 @@ std::vector<OptionHandler*> OptionHandle
+ OptionHandler* op(new NumberOptionHandler
+ (PREF_SPLIT,
+ TEXT_SPLIT,
+- "5",
++ "8",
+ 1, -1,
+ 's'));
+ op->addTag(TAG_BASIC);