summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralostengineer2015-10-12 09:35:19 -0400
committeralostengineer2015-10-12 09:35:19 -0400
commit2f69220a719e144af815f8641f42c8ea7428dd51 (patch)
treede138f029a70aaec29931c0fb4ff66afca22522b
downloadaur-2f69220a719e144af815f8641f42c8ea7428dd51.tar.gz
initial pkgbuild for aur4
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
-rw-r--r--aria2fe.desktop7
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2564676b853
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = aria2fe
+ pkgdesc = A GUI for the CLI-based aria2 download utility
+ pkgver = 0.0.5
+ pkgrel = 5
+ url = http://sourceforge.net/projects/aria2fe/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ depends = aria2
+ depends = xterm
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/aria2fe/aria2fe-0.0.5.tar.bz2
+ source = aria2fe.desktop
+ md5sums = caa4ca05dce2702de28fb8afbd34c722
+ md5sums = 36082a7cfd77b33c5b8c8ac968b52b74
+
+pkgname = aria2fe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..672e5e6e790b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Mantainer: Simone Esposito <webmaster at freebnc.net>
+
+pkgname=aria2fe
+pkgver=0.0.5
+pkgrel=5
+pkgdesc="A GUI for the CLI-based aria2 download utility"
+arch=("i686" "x86_64")
+url="http://sourceforge.net/projects/aria2fe/"
+license=("GPL3")
+depends=('qt4' 'aria2' 'xterm')
+options=(!emptydirs)
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2 ${pkgname}.desktop)
+md5sums=('caa4ca05dce2702de28fb8afbd34c722'
+ '36082a7cfd77b33c5b8c8ac968b52b74')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}/src
+ qmake-qt4
+ make
+}
+
+package() {
+ install -d ${pkgdir}/usr/{bin,share/{pixmaps,applications}}
+ install -Dm 755 ${srcdir}/${pkgname}-${pkgver}/bin/aria2fe ${pkgdir}/usr/bin/
+ install -D ${srcdir}/${pkgname}-${pkgver}/src/pixmaps/download_32x32.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -D ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/
+}
diff --git a/aria2fe.desktop b/aria2fe.desktop
new file mode 100644
index 000000000000..1ddb876bc67a
--- /dev/null
+++ b/aria2fe.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Aria2FE
+Version=0.0.5
+Icon=aria2fe
+Exec=aria2fe
+Categories=Network;