summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2023-02-01 13:20:58 -0300
committerFilipe Nascimento2023-02-01 13:21:38 -0300
commit0431d2b2c70be70dda86737eca13025ed2c1017f (patch)
tree0589a04607fab68d758c18cc37bad426cd660139
parent3fac1ee375ee72cec4be29aacfda2a079e15c487 (diff)
downloadaur-0431d2b2c70be70dda86737eca13025ed2c1017f.tar.gz
upgpkg: aria2p 0.11.3-2
add python-installer as makedepends
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf35f0f68f6..35e4073f6c4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = aria2p
pkgdesc = Command-line tool and library to interact with an aria2c daemon process with JSON-RPC
pkgver = 0.11.3
- pkgrel = 1
+ pkgrel = 2
url = https://pawamoy.github.io/showcase/aria2p
arch = any
license = ISC
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-pdm-pep517
depends = python-appdirs
depends = python-loguru
diff --git a/PKGBUILD b/PKGBUILD
index 4563ca9f5158..889b9a897daa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=aria2p
pkgver=0.11.3
-pkgrel=1
+pkgrel=2
pkgdesc="Command-line tool and library to interact with an aria2c daemon process with JSON-RPC"
arch=('any')
url="https://pawamoy.github.io/showcase/aria2p"
license=('ISC')
depends=('python-appdirs' 'python-loguru' 'python-requests'
'python-toml' 'python-websocket-client' )
-makedepends=('python-build' 'python-install' 'python-pdm-pep517')
+makedepends=('python-build' 'python-installer' 'python-pdm-pep517')
optdepends=('aria2: aria2c daemon'
'python-asciimatics: interactive interface support'
'python-pyperclip: interactive interface support')
@@ -18,12 +18,12 @@ sha256sums=('517667f7b38adde8826908d6b6fbbf862a3066a56415e0fd2fd3ba61dc9cd19d')
build() {
cd $pkgname-$pkgver
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname-$pkgver
- python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ python -m installer --destdir="${pkgdir}" dist/*.whl
chmod +x "${pkgdir}"/usr/bin/*
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}