summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2021-01-03 20:35:48 -0300
committerFilipe Nascimento2021-01-03 20:35:48 -0300
commit870d327edff78a156b7edbb1fa1780468858f151 (patch)
treea38e4fe32282673c7095ad120cb11896af40f6dd
parent61930af0a5679c7dc12adf8fb7173d6bf1333b28 (diff)
downloadaur-870d327edff78a156b7edbb1fa1780468858f151.tar.gz
upgpkg: aria2p 0.10.3-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--xdg.patch22
3 files changed, 14 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07d43388f253..fb9ff45bc050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aria2p
pkgdesc = Command-line tool and library to interact with an aria2c daemon process with JSON-RPC
- pkgver = 0.10.1
- pkgrel = 2
+ pkgver = 0.10.3
+ pkgrel = 1
url = https://pawamoy.github.io/showcase/aria2p
arch = any
license = ISC
@@ -9,14 +9,12 @@ pkgbase = aria2p
depends = python-requests
depends = python-toml
depends = python-websocket-client
- depends = python-pyxdg
optdepends = aria2: aria2c daemon
+ optdepends = python-appdirs: interactive interface support
optdepends = python-asciimatics: interactive interface support
optdepends = python-pyperclip: interactive interface support
- source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.10.1.tar.gz
- source = xdg.patch
- sha256sums = 13637e44dbeb27be4e4fe96b4dfca18857a999727852aeb59984768e33de7eb8
- sha256sums = 1ab5a896ec75ec950151cb98703c1622439b19e5e9aa6bbd4f9703224043778b
+ source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.10.3.tar.gz
+ sha256sums = bd9471d9bc51a5a51abf6efd365242c0454db85e60a2efd929ef938558b998f5
pkgname = aria2p
diff --git a/PKGBUILD b/PKGBUILD
index 23caa4440408..e3f5852a3c81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,28 @@
# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=aria2p
-pkgver=0.10.1
-pkgrel=2
+pkgver=0.10.3
+pkgrel=1
pkgdesc="Command-line tool and library to interact with an aria2c daemon process with JSON-RPC"
arch=('any')
url="https://pawamoy.github.io/showcase/aria2p"
license=('ISC')
-depends=('python-loguru' 'python-requests' 'python-toml'
- 'python-websocket-client' 'python-pyxdg')
+depends=('python-loguru' 'python-requests'
+ 'python-toml' 'python-websocket-client' )
optdepends=('aria2: aria2c daemon'
+ 'python-appdirs: interactive interface support'
'python-asciimatics: interactive interface support'
'python-pyperclip: interactive interface support')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
- "xdg.patch")
-sha256sums=('13637e44dbeb27be4e4fe96b4dfca18857a999727852aeb59984768e33de7eb8'
- '1ab5a896ec75ec950151cb98703c1622439b19e5e9aa6bbd4f9703224043778b')
-
-prepare() {
- cd ${pkgname}-${pkgver}
- patch -p1 < ../xdg.patch
-}
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('bd9471d9bc51a5a51abf6efd365242c0454db85e60a2efd929ef938558b998f5')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd $pkgname-$pkgver
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/xdg.patch b/xdg.patch
deleted file mode 100644
index 62fa5461c4ac..000000000000
--- a/xdg.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/src/aria2p/utils.py b/src/aria2p/utils.py
-index 20834d5..855ae72 100644
---- a/src/aria2p/utils.py
-+++ b/src/aria2p/utils.py
-@@ -13,7 +13,7 @@ from typing import Any, Dict, List
- import pkg_resources
- import toml
- from loguru import logger
--from xdg import XDG_CONFIG_HOME
-+from xdg import BaseDirectory
-
- from aria2p.types import PathOrStr
-
-@@ -240,7 +240,7 @@ def load_configuration() -> Dict[str, Any]:
- config_dict["DEFAULT"] = toml.loads(default_config)
-
- # Check for configuration file
-- config_file_path = Path(XDG_CONFIG_HOME) / "aria2p" / "config.toml"
-+ config_file_path = Path(BaseDirectory.save_data_path("aria2p")) / "config.toml"
-
- if config_file_path.exists():
- try: