summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2020-11-28 16:53:32 -0300
committerFilipe Nascimento2020-11-28 16:53:32 -0300
commitc160b2e67ed1530b972655ba12ae179d60e0be80 (patch)
tree682c19f05301290eca1a66b66f979db442a57aba
parente26d6679a017020028ed7c4edbf9a3b824983d84 (diff)
downloadaur-c160b2e67ed1530b972655ba12ae179d60e0be80.tar.gz
upgpkg: aria2p 0.10.1-1
upstream release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
-rw-r--r--xdg.patch22
3 files changed, 46 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9caeaf89c84b..bd4f49d15030 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = aria2p
pkgdesc = Command-line tool and library to interact with an aria2c daemon process with JSON-RPC
- pkgver = 0.9.1
+ pkgver = 0.10.1
pkgrel = 1
- url = https://github.com/pawamoy/aria2p
+ url = https://pawamoy.github.io/showcase/aria2p
arch = any
license = ISC
depends = python-loguru
depends = python-requests
+ depends = python-toml
depends = python-websocket-client
+ depends = python-pyxdg
optdepends = aria2: aria2c daemon
optdepends = python-asciimatics: interactive interface support
- source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.9.1.tar.gz
- sha256sums = f9b680c2c0d954ba7f483c6f9836104b423283136a63aeaf9606c259d45c4f45
+ optdepends = python-pyperclip: interactive interface support
+ source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.10.1.tar.gz
+ source = xdg.patch
+ sha256sums = 13637e44dbeb27be4e4fe96b4dfca18857a999727852aeb59984768e33de7eb8
+ sha256sums = 1ab5a896ec75ec950151cb98703c1622439b19e5e9aa6bbd4f9703224043778b
pkgname = aria2p
diff --git a/PKGBUILD b/PKGBUILD
index 726515201e14..e2eef299daff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,26 @@
# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=aria2p
-pkgver=0.9.1
+pkgver=0.10.1
pkgrel=1
pkgdesc="Command-line tool and library to interact with an aria2c daemon process with JSON-RPC"
arch=('any')
-url="https://github.com/pawamoy/$pkgname"
+url="https://pawamoy.github.io/showcase/aria2p"
license=('ISC')
-depends=('python-loguru' 'python-requests' 'python-websocket-client')
+depends=('python-loguru' 'python-requests' 'python-toml'
+ 'python-websocket-client' 'python-pyxdg')
optdepends=('aria2: aria2c daemon'
- 'python-asciimatics: interactive interface support')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('f9b680c2c0d954ba7f483c6f9836104b423283136a63aeaf9606c259d45c4f45')
+ 'python-asciimatics: interactive interface support'
+ 'python-pyperclip: interactive interface support')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
+ "xdg.patch")
+sha256sums=('13637e44dbeb27be4e4fe96b4dfca18857a999727852aeb59984768e33de7eb8'
+ 'ff4d67efa56bd5bc3ef53e1b229519586de140c3278086b95b57dd719bb7f5eb')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -p1 < ../xdg.patch
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/xdg.patch b/xdg.patch
new file mode 100644
index 000000000000..62fa5461c4ac
--- /dev/null
+++ b/xdg.patch
@@ -0,0 +1,22 @@
+diff --git a/src/aria2p/utils.py b/src/aria2p/utils.py
+index 20834d5..855ae72 100644
+--- a/src/aria2p/utils.py
++++ b/src/aria2p/utils.py
+@@ -13,7 +13,7 @@ from typing import Any, Dict, List
+ import pkg_resources
+ import toml
+ from loguru import logger
+-from xdg import XDG_CONFIG_HOME
++from xdg import BaseDirectory
+
+ from aria2p.types import PathOrStr
+
+@@ -240,7 +240,7 @@ def load_configuration() -> Dict[str, Any]:
+ config_dict["DEFAULT"] = toml.loads(default_config)
+
+ # Check for configuration file
+- config_file_path = Path(XDG_CONFIG_HOME) / "aria2p" / "config.toml"
++ config_file_path = Path(BaseDirectory.save_data_path("aria2p")) / "config.toml"
+
+ if config_file_path.exists():
+ try: