summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2021-01-08 13:19:49 -0300
committerFilipe Nascimento2021-01-08 13:19:49 -0300
commiteb75b197e26c5bf646c32f2a92a1b90c0cc72610 (patch)
tree64416b5961e685522282ae1bbfbb06faa1beaf07
parent870d327edff78a156b7edbb1fa1780468858f151 (diff)
downloadaur-eb75b197e26c5bf646c32f2a92a1b90c0cc72610.tar.gz
upgpkg: aria2p 0.10.4-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb9ff45bc050..18f3569b04c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = aria2p
pkgdesc = Command-line tool and library to interact with an aria2c daemon process with JSON-RPC
- pkgver = 0.10.3
+ pkgver = 0.10.4
pkgrel = 1
url = https://pawamoy.github.io/showcase/aria2p
arch = any
license = ISC
+ depends = python-appdirs
depends = python-loguru
depends = python-requests
depends = python-toml
depends = python-websocket-client
optdepends = aria2: aria2c daemon
- optdepends = python-appdirs: interactive interface support
optdepends = python-asciimatics: interactive interface support
optdepends = python-pyperclip: interactive interface support
- source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.10.3.tar.gz
- sha256sums = bd9471d9bc51a5a51abf6efd365242c0454db85e60a2efd929ef938558b998f5
+ source = https://files.pythonhosted.org/packages/source/a/aria2p/aria2p-0.10.4.tar.gz
+ sha256sums = df5e0b56768d118d9dbdc103f37cb9dda0cd82e4f9221e061ebf4a2ed375680b
pkgname = aria2p
diff --git a/PKGBUILD b/PKGBUILD
index e3f5852a3c81..4a92ec46dcc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=aria2p
-pkgver=0.10.3
+pkgver=0.10.4
pkgrel=1
pkgdesc="Command-line tool and library to interact with an aria2c daemon process with JSON-RPC"
arch=('any')
url="https://pawamoy.github.io/showcase/aria2p"
license=('ISC')
-depends=('python-loguru' 'python-requests'
+depends=('python-appdirs' 'python-loguru' 'python-requests'
'python-toml' 'python-websocket-client' )
optdepends=('aria2: aria2c daemon'
- 'python-appdirs: interactive interface support'
'python-asciimatics: interactive interface support'
'python-pyperclip: interactive interface support')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('bd9471d9bc51a5a51abf6efd365242c0454db85e60a2efd929ef938558b998f5')
+sha256sums=('df5e0b56768d118d9dbdc103f37cb9dda0cd82e4f9221e061ebf4a2ed375680b')
build() {
cd $pkgname-$pkgver