summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDct Mei2020-04-29 22:07:59 +0800
committerDct Mei2020-04-29 22:07:59 +0800
commit3caee812a8a58902d203357b6f0ddf3ada5b2c60 (patch)
tree1f49e2049aed4c8ecc0d5c9920a891c9cf08e4bd
parentb8a1fc41d725a49c0c7af6d5dfb26ee1a015409c (diff)
downloadaur-3caee812a8a58902d203357b6f0ddf3ada5b2c60.tar.gz
fix: Wrong dependency
Install the dependent environment entirely through npm, while avoiding updates and repairs.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cf59291c4b1..b601dba197f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = ariang-allinone
pkgdesc = A modern web frontend making aria2 easier to use (all-in-one version)
pkgver = 1.1.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mayswind/AriaNg
arch = any
license = MIT
makedepends = git
- makedepends = gulp
- makedepends = npm
makedepends = nvm
depends = bash
source = https://github.com/mayswind/AriaNg/archive/1.1.5.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index ad2dc0ec338a..a7e964a20f5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=ariang-allinone
pkgver=1.1.5
-pkgrel=1
+pkgrel=2
pkgdesc="A modern web frontend making aria2 easier to use (all-in-one version)"
arch=('any')
url="https://github.com/mayswind/AriaNg"
license=('MIT')
depends=('bash')
-makedepends=('git' 'gulp' 'npm' 'nvm')
+makedepends=('git' 'nvm')
source=("$url/archive/1.1.5.tar.gz"
"$pkgname.desktop"
"$pkgname.sh")
@@ -19,11 +19,9 @@ sha512sums=('ca41d9012ba5fcec5efbdae2d670064e08f4a2949087b3c4b5a62c9375060834d02
build() {
cd "AriaNg-$pkgver"
source /usr/share/nvm/init-nvm.sh
- nvm install v8.17.0
- npm update
- npm audit fix
+ nvm install 8.17.0
npm install --devDependencies
- gulp clean build-bundle
+ node_modules/gulp/bin/gulp.js clean build-bundle
}
package() {