summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpikatenor2017-04-21 01:42:27 +0900
committerpikatenor2017-04-21 01:42:27 +0900
commitf8323c06786d147ab58fa765ce033b36c5dc52d3 (patch)
treec0477f9ffe585dabc1ea91dae2f787e435f75ae2
downloadaur-f8323c06786d147ab58fa765ce033b36c5dc52d3.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d6a4b44ce34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# 木 4月 20 16:40:06 UTC 2017
+pkgbase = aribb24
+ pkgdesc = A library for ARIB STD-B24, decoding JIS 8 bit characters and parsing MPEG-TS stream.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/nkoriyama/aribb24
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = pkg-config
+ makedepends = autoconf
+ makedepends = automake
+ depends = libpng
+ source = https://github.com/nkoriyama/aribb24/archive/v1.0.3.tar.gz
+ md5sums = 5ef0a6d1d72f294666ee1489b7ebb8c5
+
+pkgname = aribb24
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e55ede14275
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ryotaro Ko <aur@p1kachu.net>
+
+pkgname=aribb24
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A library for ARIB STD-B24, decoding JIS 8 bit characters and parsing MPEG-TS stream."
+arch=('i686' 'x86_64')
+url="https://github.com/nkoriyama/aribb24"
+license=('LGPL3')
+depends=("libpng")
+makedepends=("pkg-config" "autoconf" "automake")
+
+source=("https://github.com/nkoriyama/$pkgname/archive/v$pkgver.tar.gz")
+
+md5sums=("5ef0a6d1d72f294666ee1489b7ebb8c5")
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}