summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2017-01-22 14:30:22 +0100
committerMuflone2017-01-22 14:30:22 +0100
commiteabef4d6d102c5bc1cfc59efc01e8f1e23aa31a5 (patch)
tree4fd0ba95a0b02dcf845435c382d73b85b036df51
downloadaur-eabef4d6d102c5bc1cfc59efc01e8f1e23aa31a5.tar.gz
Moving from community
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD42
-rw-r--r--fix-for-python2.patch99
-rw-r--r--gst-webkit-imports.patch30
-rw-r--r--remove-arista-nautilus_py.patch11
5 files changed, 218 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e276bf2980ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Sun Jan 22 13:26:52 UTC 2017
+pkgbase = arista
+ pkgdesc = Easy to use multimedia transcoder for the GNOME Desktop
+ pkgver = 0.9.7
+ pkgrel = 12
+ url = http://transcoder.org/
+ arch = any
+ license = LGPL2.1
+ depends = pygtk
+ depends = python2-gconf
+ depends = python2-dbus
+ depends = librsvg
+ depends = python2-gudev
+ depends = gstreamer0.10-python
+ depends = desktop-file-utils
+ optdepends = pywebkitgtk: show in-app codecs help
+ optdepends = python2-notify: show notifications in your desktop environment
+ optdepends = gstreamer0.10-ffmpeg: enable FFMpeg based audio/video plugins
+ optdepends = gstreamer0.10-base-plugins: enable basic set of well-supported audio/video plugins
+ optdepends = gstreamer0.10-good-plugins: enable a set of well-supported free audio/video plugins
+ optdepends = gstreamer0.10-bad-plugins: enable a set of less supported audio/video plugins
+ optdepends = gstreamer0.10-ugly-plugins: enable a set of well-supported non-free audio/video plugins
+ conflicts = arista-transcoder
+ replaces = arista-transcoder
+ source = arista-0.9.7.tar.gz::https://github.com/danielgtaylor/arista/archive/0.9.7.tar.gz
+ source = fix-for-python2.patch
+ source = gst-webkit-imports.patch
+ source = remove-arista-nautilus_py.patch
+ sha256sums = 87d5530d9c7bf2b8ca60f0d356b1a7e431e1798f72db8c5f14f1eba6cecd1cca
+ sha256sums = 7f783c54122eb4b47b121a3a47ee69d552cb6f1b5a78ed6836b48f12d2b1883d
+ sha256sums = 625c2767a36e591b38ef31e28dddb8e45218b632ce2a150f12ed2eed34746406
+ sha256sums = 704fd490fb48e334abc84274e6e9012bd514afd4cf33313dd34fc96eacf83c7b
+
+pkgname = arista
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c6df5d5eb9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 174186 2016-05-07 16:10:24Z muflone $
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: SergHeart
+
+pkgname=arista
+pkgver=0.9.7
+pkgrel=12
+pkgdesc="Easy to use multimedia transcoder for the GNOME Desktop"
+arch=('any')
+url="http://transcoder.org/"
+license=('LGPL2.1')
+depends=('pygtk' 'python2-gconf' 'python2-dbus' 'librsvg' 'python2-gudev' 'gstreamer0.10-python' 'desktop-file-utils')
+optdepends=('pywebkitgtk: show in-app codecs help'
+ 'python2-notify: show notifications in your desktop environment'
+ 'gstreamer0.10-ffmpeg: enable FFMpeg based audio/video plugins'
+ 'gstreamer0.10-base-plugins: enable basic set of well-supported audio/video plugins'
+ 'gstreamer0.10-good-plugins: enable a set of well-supported free audio/video plugins'
+ 'gstreamer0.10-bad-plugins: enable a set of less supported audio/video plugins'
+ 'gstreamer0.10-ugly-plugins: enable a set of well-supported non-free audio/video plugins')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/danielgtaylor/${pkgname}/archive/${pkgver}.tar.gz"
+ "fix-for-python2.patch"
+ "gst-webkit-imports.patch"
+ "remove-arista-nautilus_py.patch")
+sha256sums=('87d5530d9c7bf2b8ca60f0d356b1a7e431e1798f72db8c5f14f1eba6cecd1cca'
+ '7f783c54122eb4b47b121a3a47ee69d552cb6f1b5a78ed6836b48f12d2b1883d'
+ '625c2767a36e591b38ef31e28dddb8e45218b632ce2a150f12ed2eed34746406'
+ '704fd490fb48e334abc84274e6e9012bd514afd4cf33313dd34fc96eacf83c7b')
+conflicts=('arista-transcoder')
+replaces=('arista-transcoder')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i "../fix-for-python2.patch"
+ patch -p1 -i "../gst-webkit-imports.patch"
+ # The script arista-nautilus.py doesn't work with Nautilus 3.x
+ patch -p1 -i "../remove-arista-nautilus_py.patch"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}"
+}
diff --git a/fix-for-python2.patch b/fix-for-python2.patch
new file mode 100644
index 000000000000..ef8eb6555506
--- /dev/null
+++ b/fix-for-python2.patch
@@ -0,0 +1,99 @@
+diff -Naur arista-0.9.7.orig/arista/__init__.py arista-0.9.7/arista/__init__.py
+--- arista-0.9.7.orig/arista/__init__.py 2011-01-24 22:41:29.000000000 +0100
++++ arista-0.9.7/arista/__init__.py 2014-06-08 19:51:38.950314069 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Transcoder Library
+diff -Naur arista-0.9.7.orig/arista/inputs/haldisco.py arista-0.9.7/arista/inputs/haldisco.py
+--- arista-0.9.7.orig/arista/inputs/haldisco.py 2011-05-27 17:49:00.000000000 +0200
++++ arista-0.9.7/arista/inputs/haldisco.py 2014-06-08 19:52:09.766980512 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Input Device Discovery
+diff -Naur arista-0.9.7.orig/arista/inputs/__init__.py arista-0.9.7/arista/inputs/__init__.py
+--- arista-0.9.7.orig/arista/inputs/__init__.py 2011-06-17 22:46:02.000000000 +0200
++++ arista-0.9.7/arista/inputs/__init__.py 2014-06-08 19:52:12.686980492 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Input Device Discovery
+diff -Naur arista-0.9.7.orig/arista/inputs/udevdisco.py arista-0.9.7/arista/inputs/udevdisco.py
+--- arista-0.9.7.orig/arista/inputs/udevdisco.py 2011-05-27 17:49:10.000000000 +0200
++++ arista-0.9.7/arista/inputs/udevdisco.py 2014-06-08 19:52:14.726980475 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Input Device Discovery
+diff -Naur arista-0.9.7.orig/arista/presets.py arista-0.9.7/arista/presets.py
+--- arista-0.9.7.orig/arista/presets.py 2011-06-16 02:14:43.000000000 +0200
++++ arista-0.9.7/arista/presets.py 2014-06-08 19:51:42.280314045 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Presets
+diff -Naur arista-0.9.7.orig/arista/queue.py arista-0.9.7/arista/queue.py
+--- arista-0.9.7.orig/arista/queue.py 2011-06-17 23:09:48.000000000 +0200
++++ arista-0.9.7/arista/queue.py 2014-06-08 19:51:25.120314168 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Queue Handling
+diff -Naur arista-0.9.7.orig/arista/transcoder.py arista-0.9.7/arista/transcoder.py
+--- arista-0.9.7.orig/arista/transcoder.py 2011-06-17 17:09:31.000000000 +0200
++++ arista-0.9.7/arista/transcoder.py 2014-06-08 19:51:47.443647340 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Transcoder
+diff -Naur arista-0.9.7.orig/arista/utils.py arista-0.9.7/arista/utils.py
+--- arista-0.9.7.orig/arista/utils.py 2011-06-11 15:59:17.000000000 +0200
++++ arista-0.9.7/arista/utils.py 2014-06-08 19:51:49.763647324 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Arista Utilities
+diff -Naur arista-0.9.7.orig/arista-gtk arista-0.9.7/arista-gtk
+--- arista-0.9.7.orig/arista-gtk 2011-06-20 16:10:53.000000000 +0200
++++ arista-0.9.7/arista-gtk 2014-06-08 19:51:11.363647601 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+
+ """
+ Arista Desktop Transcoder (GTK+ client)
+diff -Naur arista-0.9.7.orig/arista-transcode arista-0.9.7/arista-transcode
+--- arista-0.9.7.orig/arista-transcode 2011-06-16 02:21:39.000000000 +0200
++++ arista-0.9.7/arista-transcode 2014-06-08 19:51:07.286980965 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # -*- coding: UTF-8 -*-
+
+ """
+diff -Naur arista-0.9.7.orig/setup.py arista-0.9.7/setup.py
+--- arista-0.9.7.orig/setup.py 2011-06-20 16:11:26.000000000 +0200
++++ arista-0.9.7/setup.py 2014-06-08 19:50:55.606981050 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import os
+ import sys
diff --git a/gst-webkit-imports.patch b/gst-webkit-imports.patch
new file mode 100644
index 000000000000..446df2d39eec
--- /dev/null
+++ b/gst-webkit-imports.patch
@@ -0,0 +1,30 @@
+diff -Naur arista-0.9.7.orig/arista-gtk arista-0.9.7/arista-gtk
+--- arista-0.9.7.orig/arista-gtk 2011-06-20 16:10:53.000000000 +0200
++++ arista-0.9.7/arista-gtk 2014-06-08 19:58:38.190311033 +0200
+@@ -59,12 +59,6 @@
+ pynotify = None
+ _log.info("Unable to import pynotify - desktop notifications disabled")
+
+-try:
+- import webkit
+-except ImportError:
+- webkit = None
+- _log.info("Unable to import webkit - in-app documentation disabled")
+-
+ import arista
+
+ _ = gettext.gettext
+@@ -2334,6 +2328,13 @@
+ import gst
+ import gst.pbutils
+
++ # FIXME: if webkit is imported before gst the whole application hangs indefinitely
++ try:
++ import webkit
++ except ImportError:
++ webkit = None
++ _log.info("Unable to import webkit - in-app documentation disabled")
++
+ arista.init()
+
+ lc_path = arista.utils.get_path("locale", default = "")
diff --git a/remove-arista-nautilus_py.patch b/remove-arista-nautilus_py.patch
new file mode 100644
index 000000000000..8fc1f50bd320
--- /dev/null
+++ b/remove-arista-nautilus_py.patch
@@ -0,0 +1,11 @@
+diff -Naur arista-0.9.7-orig/setup.py arista-0.9.7/setup.py
+--- arista-0.9.7-orig/setup.py 2011-06-20 16:11:26.000000000 +0200
++++ arista-0.9.7/setup.py 2014-09-20 17:59:52.603607332 +0200
+@@ -25,7 +25,6 @@
+ (os.path.join("share", "doc", "arista"), [
+ "README.md", "LICENSE", "AUTHORS"
+ ]),
+- (os.path.join("share", "nautilus-python", "extensions"), ["arista-nautilus.py"]),
+ ]
+
+ for (prefix, path) in [("arista", "presets"),