summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2021-06-06 18:19:53 +0200
committerD3SOX2021-06-06 18:19:53 +0200
commitf0c604036de4d7f6b00f37ded7c38ffbcf6411f1 (patch)
tree7f8dc2d381264e79e76223aa106af8b29b5dabee
downloadaur-f0c604036de4d7f6b00f37ded7c38ffbcf6411f1.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..213e494f9c02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = aritim-dark-gtk-git
+ pkgdesc = A Dark theme for GTK based DEs, deeply inspired by the Ayu Dark color palette.
+ pkgver = r108.a908770
+ pkgrel = 1
+ url = https://github.com/Mrcuve0/Aritim-Dark
+ arch = any
+ license = GPL3
+ makedepends = git
+ optdepends = aritim-dark-kde-git: Matching KDE theme
+ provides = aritim-dark-gtk
+ options = !strip
+ source = git+https://github.com/Mrcuve0/Aritim-Dark.git
+ sha256sums = SKIP
+
+pkgname = aritim-dark-gtk-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91d3b16e7190
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Nico <d3sox at protonmail dot com>
+# Contributor: Bradley Ridnour <bradley@ridnour.net>
+pkgname=aritim-dark-gtk-git
+_pkgname=Aritim-Dark
+pkgver=r108.a908770
+pkgrel=1
+pkgdesc="A Dark theme for GTK based DEs, deeply inspired by the Ayu Dark color palette."
+arch=(any)
+url="https://github.com/Mrcuve0/$_pkgname"
+provides=('aritim-dark-gtk')
+optdepends=('aritim-dark-kde-git: Matching KDE theme')
+license=('GPL3')
+options=('!strip')
+source=("git+$url.git")
+sha256sums=('SKIP')
+makedepends=('git')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+shopt -s extglob
+
+package() {
+ cd $_pkgname
+
+ mkdir -p "${pkgdir}/usr/share/themes/Aritim-Dark"
+ cp -r GTK/* ${pkgdir}/usr/share/themes/Aritim-Dark
+}