summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBradley Ridnour2020-12-02 18:17:22 -0500
committerBradley Ridnour2020-12-02 18:17:22 -0500
commit63d8e0457c08cf44c02719425fd802c6b6462214 (patch)
tree01575adc52e370bc48e12677aa1b3f9e466c4931
downloadaur-63d8e0457c08cf44c02719425fd802c6b6462214.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ff117471529
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = aritim-light-gtk
+ pkgdesc = A Light theme for KDE and GTK based DEs, deeply inspired by the Ayu Light color palette.
+ pkgver = r41.89a25fe
+ pkgrel = 1
+ url = https://github.com/Mrcuve0/Aritim-Light
+ arch = any
+ license = GPL3
+ makedepends = git
+ options = !strip
+ source = git+https://github.com/Mrcuve0/Aritim-Light.git
+ sha256sums = SKIP
+
+pkgname = aritim-light-gtk
+ optdepends = aritim-light-kde: Matching KDE theme
+ provides = aritim-light-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2bb0bb7aa28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bradley Ridnour <bradley@ridnour.net>
+pkgname=aritim-light-gtk
+_pkgname=Aritim-Light
+pkgver=r41.89a25fe
+pkgrel=1
+pkgdesc="A Light theme for KDE and GTK based DEs, deeply inspired by the Ayu Light color palette."
+arch=(any)
+url="https://github.com/Mrcuve0/$_pkgname"
+license=('GPL3')
+options=('!strip')
+source=("git+$url.git")
+sha256sums=('SKIP')
+makedepends=('git')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+shopt -s extglob
+
+package_aritim-light-gtk() {
+ provides=('aritim-light-gtk')
+ optdepends=('aritim-light-kde: Matching KDE theme')
+
+ cd $_pkgname
+
+ mkdir -p "${pkgdir}/usr/share/themes/Aritim-Light"
+
+ cp -r GTK/* ${pkgdir}/usr/share/themes/Aritim-Light
+}