summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormetscoin2018-07-18 09:27:43 -0400
committermetscoin2018-07-18 09:27:43 -0400
commit2f62eab4f739f370bddef6068e91e0189afce78b (patch)
tree63622b55efd4dfe6c48aaab69f0605cec77adad0
downloadaur-2f62eab4f739f370bddef6068e91e0189afce78b.tar.gz
Init arizen repo
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD22
-rw-r--r--arizen.install19
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb87e6becb79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = arizen
+ pkgdesc = Arizen is light API wallet for ZenCash with localy stored and encrypted files.
+ pkgver = 1.1.8
+ pkgrel = 1
+ url = https://github.com/ZencashOfficial/arizen
+ install = arizen.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = atk
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = electron
+ depends = expat
+ depends = fontconfig
+ depends = gconf
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libcups
+ depends = libnotify
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = opera
+ depends = pango
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/ZencashOfficial/arizen/releases/download/v1.1.8/Arizen_1.1.8_amd64.deb
+ sha256sums = 3e816c70b95bbad0b4a907a6bc028371efa07c044e94c87c975fde51073dc3d3
+
+pkgname = arizen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..585849f4d8ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=arizen
+pkgver=1.1.8
+pkgrel=1
+pkgdesc="Arizen is light API wallet for ZenCash with localy stored and encrypted files."
+arch=('i686' 'x86_64')
+url="https://github.com/ZencashOfficial/arizen"
+license=('MIT')
+groups=('')
+depends=('alsa-lib' 'atk' 'cairo' 'dbus' 'desktop-file-utils' 'electron' 'expat' 'fontconfig' 'gconf' 'gdk-pixbuf2' 'glib2' 'gtk3' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libcups' 'libnotify' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'opera' 'pango')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source=("https://github.com/ZencashOfficial/arizen/releases/download/v1.1.8/Arizen_1.1.8_amd64.deb")
+sha256sums=('3e816c70b95bbad0b4a907a6bc028371efa07c044e94c87c975fde51073dc3d3')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+}
diff --git a/arizen.install b/arizen.install
new file mode 100644
index 000000000000..2f5b00e3b61c
--- /dev/null
+++ b/arizen.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Arizen/arizen' '/usr/bin/arizen'
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/arizen'
+ update-desktop-database -q
+}